Can't get toolbar favourites to appear on one line

I have Favourites and SmartFavourites shown in one toolbar - I've set it to show icons for both.

However, it ends up like this:


I don't seem to be able to get the normal favourites to go on one line.

Here's the settings for both:


Even though it's not checked, check the "Show label" box and set the dropdown to the same setting for both. Then uncheck the box and see what happens.

D'oh - Yeah that fixed it, although specifically I turned on Show label and set it to 'right'. I could have sworn I'd tried that though!


Thanks!