GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Can't install Opus 12 on Win 10: error 0x8000FFFF


#21

@matcat:

I don't have any solid ideas beyond the ones you've already tried, I'm afraid.

I've spent a long time comparing your log to the log from a successful install on Windows 8.1 (64-bit) and, apart from the install path oddity, everything looks about the same up until the point that the uninstaller information is recorded into the registry. (I'm not sure if that is actually important, though. I can't see any errors in your log showing that it tried to write that information but failed, so it seems unlikely it is the cause.)

The log shows the Windows antivirus scanner working through everything the installer is writing just after it writes it, which might be significant. Disabling the scanner may be worth a try. A different installer may also be wroth a try, just in case there's something peculiar going on with a particular file/signature in the one you're using.

(I recommend the 12.2.4 beta installer linked in my signature, if you want to try a different one. It's proven to be a stable release, and the only reason it's still called a beta is there are some English strings that haven't been translated to other languages yet.)

Going back to the install path oddity, was the system migrated from 32-bit to 64-bit at some point int he past, using one of the tools that attempts to do that? That might explain the confusion there.

I also noticed some registry access to do with application compatibility flags, which could be causing both the install path oddity and the overall problem, but may also be perfectly normal. It's hard to tell from what's in the log. Those settings are in the registry but I'm not sure if there is a good way to view them. If you're comfortable using RegEdit, you might want to check under these places:

  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
    • Compatibility Assistant
      • Persisted
      • Store
    • Layers

and the same HKEY_LOCAL_MACHINE equivalents

for any keys/values with DOpusInstall.exe or ISBEW64.exe in their names.

The ISBEW64.exe one in particular, since it's possible another InstallShield installer triggered compatibility flags to be turned on by the OS automatically for something with the same name.... It's quite a long shot, though.

Peterb's suggestion of trying the install from a different account is a good idea. Sometimes a profile or permissions problem can break things, where a fresh account allows them to succeed. (The program may then work from the main account, or it would at least give us something more to go on.)

The other installer and/or disabling antivirus would be the first things I would try though, since they are the most simple.


#22

OK I figured out what the problem was. Quick answer, I had changed the location of my local user temp folder to a custom location by changing the environmental variable, as well as used a symlink at some point because moving the temp folder had caused me issues with installing nvidia geforce experience updates at one point. I can't remember exactly what I was using the symlink for but it allowed me to have the temp folder moved to where I wanted it and still be able to upgrade geforce experience without getting errors. I changed the environmental variable back to the default location and the dopusinstaller detected where to install correctly, being Program Files, and not Program Files (x86). The install completed without error after that. I had been trying to spare my ssd the unecessary writes but I'll just leave it at default at this point, being this is the second time I've run into trouble. Thanks for your time and effort in looking into this issue for me and I'm sorry to have used up some of your time on a likely rare issue. Have a good one.


#23

Glad you got it sorted! And thanks for letting us know what the fix was. That might come in handy if someone else runs into a similar problem.


#24

Same problem for me. But, im on Win7 64bit. I have my tmp and temp on a different drive (not C), its also an SSD. Why do I have to change my system just to make this program install? Surely this is a problem with the programs installer not our computers?

I have a code from Humble Bundle which I never used until they reminded me this week the code (allowing one-off install) is going to run out on May 1st. I guess you wont be fixing this in the next couple of days since it was first reported almost a year ago :confused:


#25

The deadline is only to redeem the Humble Code, not to install the program. If you haven't already, I believe you can redeem the Humble Code here. If you have problems, please email Sales and I'm sure they'll help there.

For the installer, Opus uses the standard InstallShield installer, so any problems with the Temp folder I would expect to also affect other things. It may not be that the temp folder was moved, but something to do with the permissions in the new folder, using symlinks (if you've done the same as the earlier poster), or not updating all of the environment variables and other system settings to point to the new folder.

If the temp folder is moved then I'd expect things to work OK, as it has not always been in the same place in every version of Windows, without problems, and its path in modern versions of Windows depends on the account name. So InstallShield definitely doesn't have the temp path hardcoded, or it would not work at all.

It's possible InstallShield needs temp be on the C drive, if it assumes it can rename things between the temp folder and other C drive locations, but I can only speculate. We have never seen the issue on our own machines to investigate it, nor had more than the three reports (including yours) in this thread over the years, or full knowledge of how those machines were set up.

If you open a Command Prompt and type set t, where does it indicate the TEMP and TMP env-vars are pointing? Do they point to the correct location on your machine?

What are the file/folder permissions, and (account) ownership, on the temp folder?


#26

Thanks for the suggestions, I tried to register the code via the website with the following issues:

  1. the code is too long to fit in the form. So had to take out one of the hyphens
  2. it rejects the form saying 'The Boxed Product Code you provided was either not valid or has already been registered.

Resonably sure it rejects it because the form you linked appears to be for the boxed product only

What do you mean by the instruction saying 'Do they point to the correct location on your machine?'. I can point my tmp and temp anywhere I want? Do you mean does the location I point my variables to, actually exist?


#27

When you copy and paste the code make sure there's no white space before or after it.


#28

Are the variables consistent with where the folder is? Windows has several independent settings that point to the temp folder and it's possible to change some and not all of them, which will break things which use one method to find the folder instead of the others.

The permissions on the temp folders and files within them are also vital. For example, if SYSTEM doesn't have access to the temp folder then many installers will break. The ownership may also be important, from what I've read.

It's also worth keeping in mind that Windows has multiple temp folders. The user-specific temp folders and the Windows/system temp folder. Different accounts will use different folders, and should have independent env-var/registry settings pointing to them, and the folders will be permissioned differently and owned by different accounts.

(I would also ask myself whether the possible benefits of moving the temp folder to another drive are worth the potential to cause problems due to a non-standard configuration or missed setting/permission. It's your PC and up to you if that trade-off makes sense.)

See Jon's post just above mine regarding the licence code.


#29

Managed to register the code via the website (thanks Jon for the suggestion), must have been white space in the code

No joy with the temp/tmp

'set t' shows locations which do exist and it is where I expect the files to go (ie to folders on secondary SSD - not on C)

System has full security control settings on both directories and subdirectories


#30

I encountered the same problem when installing Opus 12 and Autocad LT 2018 on HP Spectre 360x 15".
In the forum for Autocad I found the described solution that helped me for both installations:


#31

Hi! I am having the same issue as quite a few others seem to have had, with the error 0x8000fff coming up every time I try to install the program. I have attempted all of the suggestions listed here, to the best of my limited ability, and have no idea what else to try. I created a log file using the Process Monitor program, as suggested, and would like to send it to whoever knows how to read the result. Would you please let me know who I should send this to? Thanks in advance!


#32

Please save the log in .PML format and then zip it, and email it to crashdumps@gpsoft.com.au and we'll take a look.


#33

Hi,

...same weird problem with my DirOpus 12.11: I have made many attempts to get it installed, without any success. Pretty time-consuming and frustrating... :disappointed:

Installation ends up with that well-known error message:
Directory%20Opus%20Setup%20Error%2001

DirOpus Setup seems to recognize my 64-bit OS, but uses wrong installation path **C:\Program Files (x86)**. I forced it to use *C:\Program Files* instead. This works, but leads to the same error message.

I tried several methods & workarounds as described here:

(1) Empty InstallShield folders (if existing and as far as possible)
(2) Change location of Windows TEMP folder temporarily
(3) Deactivate anti-virus & firewall (as far as possible)
(4) Install Setup files from another drive / path
(5) Use Universal or German Installer (setup files not corrupted)
(6) Use an installation monitor (CrystalIDEA Uninstall Tool) or not
...and some more options I've already forgotten;-/

Never before I had trouble installing DirOpus. It installed perfectly on Windows 7 (Opus 11.19) on several builds and configurations (x86, x64 etc.).
Any other software installed without any problems on that specific machine. So I can't believe that there's a problem with my Windows configuration or even my PC).

Some additional facts:

  • Windows 10 Home x64, Latest Version 1809 Build 17763.195 (German), pre-Installed by PC manufacturer / updated by myself
  • System Partition on SSD + Data Partition on HDD
  • ESET Internet Security 12.0.31.0

Anybody out there who can help me?
I really love Directory Opus and miss it. There must be a way to get it back to work!?

P.S.
Sorry for my poor English. I'm a native German speaker, but prefer this support forum (not the German one, which is less helpful and up-to-date)


#34

Sorry the installer isn't working for you.

Have you checked the digital signature on the installer? Sometimes browsers don't download the complete file, and InstallShield isn't always good at noticing. The signature is a quick way to verify the download is complete.

Please make a Process Monitor log of what happens when you use the installer, and link your account, and we'll try to work out what's going wrong:


#35

Hi Leo,

thanks for your quick response.

As recommended, I've linked my Opus Pro license to my account.

It seems that the digital signature is valid:

(Note: To eliminate any browser influence, I downloaded the setup file twice with two different browsers and the result was identical (same file size, same signatures).

I will send you the Process Monitor file via private mail. Hopefully it works despite the huge zip file...

Thanks in advance for your kind support!

Kind regards
Workaholic


#36

Are any compatibility options turned on? If it's picking up Program Files (x86) that suggests its running in compatibility mode for XP (i.e. 32 bit).


#37

That seems very odd.

Have you used any "32 to 64 bit migration" tools, or imported your registry from a 32 bit machine to the 64 bit one? (Both are generally bad ideas.)

Jon's comment above mine about checking Compatibility Settings for the installer .exe is also worth a check.

If you've downloaded the installer with different browsers and the files are identical then we can probably rule that out.

But, for future reference, the screenshot only shows that the signatures exist, not that the signatures are correct. You need to click one of the signatures and then click Details to verify it. (The Windows digital signatures UI is sadly terrible.)

I've had a long look at the log file and compared it to what happens on a successful install.

Aside from the (x86) path issue you mentioned, a couple of other things stand out:

  • UninstallTool.exe seems to be looking at the files the installer is creating. It may be interfering with the install, and I'd advise removing that tool to see if it makes a difference.

  • The installer fails to run any other .exe files. Everything looks normal until the point where it should run one of the secondary .exe files that it extracts from inside itself; at that point things diverge, and the secondary process never starts.

    Something may be blocking it from creating processes, or from running .exe files out of the temp folder. If your antivirus, system policies or temp-folder permissions block things from being executed out of temp, or by 'unknown processes' (e.g. a whitelist) then that will explain why the installer is failing.

    (Temp folder as in C:\Users\<username>\AppData\Local\Temp not the other one named TEMP that the main installer is in.)


Another thing to check, what do you get if you run set programfiles from a command prompt?

And under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion in the registry?


#38

Hi Jon,

thanks for your compatibility note. I agree: The behaviour of the installer is very odd, especially the wrong installation path. I've no idea why this is happening...

To answer your question:
I didn't find any anomalies about compatibility settings in the Properties windows of DOpusInstall.exe. See screenshot:

As you can see, the compatibilty mode is not activated (and has never been).
Or are there any other compatibilty settings I didn't consider?

[Sorry, all GFX are in German language, but I hope you'll understand even though.]


#39

Hi Leo,

first of all, thanks again for your efforts to get my crazy installer working :wink:
I will try to answer all your questions below.

None of that.
As mentioned, my new PC system came with pre-installed Windows 10 Home x64 (OEM). The only remarkable things I did after unboxing the PC was installing security & functional updates and optimizing the privacy settings. And of course, I installed several programs. They all installed run without notable problems -- except Opus :disappointed:

Thanks a lot!

Interesting point... I tried to shut down all security functions during installation (av, firewall), and even stopped Windows Defender (everything with disconnected internet, of course).
Nevertheless, there may be some background security processes still working. It's pretty hard to halt all of them...
But even then there's no explanation why all the other software was installed properly and why Opus uses wrong installation path.

Are there maybe any known issues linked with latest Windows 10 October release (which ist still buggy) or ESET Internet Security?


#40

Addendum:
I checked that -- everything is set correctly, both in command prompt and in the registry.

Question:
To avoid any interferences with Windows modules, drivers etc.: Is it worth a try installing Opus after booting Windows in secure mode?

Kind regards
Workaholic