Can't Open Listers When IE6 is Open


When I have IE6 open and try to open a local folder (lister) it locks up the whole machine, I have to alt+crtl+del and restart. I have tried with IE7, I have tried uninstalling DOpus and reinstalling, I've tried disabling all spyware and AV programs and it still does it. Windows Explorer works fine.

If anyone has any ideas or suggestions I would be very grateful.

Thank You

Machine Info:

P4 3.4GHz
2 - WD SATA Raptor 150 in RAID 0
2 - WD SATA 250 GB in RAID 1
2 - WD SATA 500 GB (non-RAID)
Promise Fast-Trak TX 4310 Raid Card
ATI 850-Pro Video Card
Auzen X-Meridian 7.1 Sound Card
Samsung DVDR
On board Marvell Yukon Nic card

Installed Software:

WinXp Pro SP2 (up to date)
Directory Opus 8
SpySweeper with Anti-Virus
Spyware Blaster
Avast AV (not running resident)
Ace Utilities
Mozilla Thunderbird
Mozilla Firefox 2, IE6, Opera, (and a bunch of older browsers as this is a web design machine).
Acronis TrueImage 9
Photoshop, Illustrator, Dreamweaver 8, etc.
Microsoft Office XP (with all the latest updates)
Perfect Disk 7

Try opening Opus in various ways to see if they all cause the lock-up. It might be tied to a particular method of opening Opus, or tied to a particular starting directory.

For example, try these:

[ul][li]Open lister by double-clicking the tray icon.[/li]
[li]Open lister by double-clicking the desktop (in an empty space).[/li]
[li]Open lister by right-clicking the desktop and choosing New Lister.[/li]
[li]Open lister by double-clicking a folder or folder shortcut on the desktop.[/li]
[li]Try the previous step, but a different folder that's likely to have different files in it (or no files at all).[/li]
[li]Open Opus Preferences window from the tray icon's right-click menu.[/li]
[li]Open Opus Preferences window from the desktop's right-click menu.[/li][/ul]
Let us know how the results go. Hopefully some methods will cause the problem and not others, so we can narrow down what's behind it.

From your list of software, the only things which stands out to me are the two anti-spyware programs and Ace Utilities.

I don't know either of the anti-spyware tools well so I'm only guessing at possible situations, but it's possible that they try to protect IE6 from toolbars etc. being installed in a way which causes Opus problems. (Opus doesn't install anything in IE, but it does load a lot of different COM objects, so anything which intercepts COM object loading might cause a problem. This is a total guess, though.)

Ace Utilities looks like one of the registry "cleaner" programs. I don't know if it's a good one or not but this kind of tool can often break things by removing things from the registry that it doesn't think are needed when they actually are. Again, just a guess, not something that's definitely true.

If you can get the Opus Preferences dialog to open then there are a few things that we can try disabling to see if they help. Let me know if you can and I'll make a list of all the options that are worth a try.

Another thing that is worth doing is to run ProcessMonitor in the background while Opus starts. ProcessMonitor tells you which files and registry settings are being accessed on your computer. This may let you see the last files or COM objects which Opus accesses before the crash and that may point towards what's wrong.

First off, thank you for your fast reply, it is a pleasure doing business with a company that offers such excellent support. I really love Directory Opus and hope we can solve this. Thank you.

Here are some results.

The problem is at it's worst when I have Thunderbird open (and reading a message) and IE6 browser windows open.

I have two shortcuts to listers in my QuickLaunch that I rely heavily on. One is a shortcut to My Computer With Folder Tree on the left and My Computer on the right in Details view showing all drives, Control Panel, Macromedia FTP and Shared Documents.
The other is to my main work directory, Same layout, on the right has probaby 200 folders in it with all kinds of content in each folder/sub folders; html, php, photoshop, Illustrator files, jpg, gif, png, flash, etc.

Those two and any folder on the desktop are real problems.

• Open lister by double-clicking the tray icon. Locks Up
• Open lister by double-clicking the desktop (in an empty space). No Problems
• Open lister by right-clicking the desktop and choosing New Lister. No Problems
• Open lister by double-clicking a folder or folder shortcut on the desktop. Locks Up
• Try the previous step, but a different folder that's likely to have different files in it (or no files at all). Locks Up with any folder, empty or not
• Open Opus Preferences window from the tray icon's right-click menu. Locks Up
• Open Opus Preferences window from the desktop's right-click menu. No Problems

There is something weird about Mozilla Thunderbird.

I uninstalled DOpus and using Windows Explorer couldn't reproduce these problems.

Also here's another issue that popped up at, I think the same time this one. Clicking links in Thunderbird and GAIM does the same thing, locks up. But that may be an IE/SpySweeper/Ad Muncher problem and nothing to do with this problem or DOpus.

And something else weird is these things happen randomly, sometimes everything will be just fine and then it starts acting up.

Ace Utilities is a pretty fair utility, I've been using it for a few years and on a very rare occasion the reg cleaner can cause a problem. What I do and I will do this with DOpus: Uninstall the app, clean the reg, reboot, clean the reg again and reinstall the app. Then I will run the reg cleaner and anything that comes to be cleaned I will set Ace reg cleaner to ignore. After the latest reinstall of DOpus I went and checked this and there were no references to DOpus but that doesn't mean it didn't remove something I needed. I'll try this and see what happens and post results.


For what it's worth, I'm not from GPSoft and these forums are for user-to-user discussion, rather than an official support channel. That said, the GPSoft guys also read and post here (time permitting) and we've got a good community of helpful people here who you can depend on to help.

If you do need the official support channel it's at but, with this kind of open-ended question, I'd say you've come to the right place since there may be other people reading the forum who have experienced something similar and have suggestions.

To keep things simple, please try to avoid opening that directory until we get to a stage where an empty directory is working. I say this because there may be more than one problem and that could really confuse things. For example, sometimes either viewer plugins or shell extensions crash when they encounter certain files. In a directory with a lot of files, and many different types of files, there's a chance that one of the files is causing a crash which isn't related to the other problem.

There's a FAQ which guides you through working out if certain files or types of files are causing a crash and what to do if they are but I would say we're better off leaving that potential issue for now and concentrating on the more simple case of an empty directory. Once that works we can see if the big directory works.

There could be a problem in the registry, or something interfering with DDE or a similar launch system, which is causing the problem with all three programs (Opus, Thunderbird and GAIM). At least, if you meant that you were clicking on HTTP:// links in the other two programs. (For what it's worth, I ran Thunderbird and Opus side-by-side for a long time without any conflicts.)

If you go to Start->Run, type and then hit return, does that work okay?

It's possible that anti-spyware/virus software is blocking programs from launching URLs and folders. You said you tried disabling those tools but, at least if we get stuck, it may be worth a try completely removing them. I don't know about these particular tools but I know that others (e.g. ZoneAlarm) can cause problems even when disabled, while unisntalling them can make the issues go away. Not guaranteed but worth a try, especially if reinstalling them isn't a hassle.

From what you describe, it looks like the Desktop menu works okay while opening from the tray icon or shortcuts doesn't work:

[ul][li]Desktop double-click (in empty space).[/li]
[li]Desktop context menu, New Lister.[/li]
[li]Desktop context menu, Preferences.[/li][/ul]
Not working:
[ul][li]Tray icon double-click.[/li]
[li]Tray icon menu, Preferences.[/li]
[li]Desktop shortcuts.[/li][/ul]

Could you open Preferences and go to Double-Click - Desktop, then confirm that the Desktop and Tray Icon settings do the same thing? If they are identical, could you quickly do a sanity check and first open the lister using the method which works (Desktop double-click), then close it and try the method which doesn't work (Tray icon double-click).

Between doing the two tests, please ensure you don't change directories or anything. Just open a lister, close it, then try to open it via the other method.

If both methods are configured to do exactly the same thing and one method works but then other immediately fails then we can rule several things out as the issue must be down to the mechanisms, rather than what is being triggered by them.

Hi Nudel,

Sorry for not getting back sooner but for some reason I never got an email notifying me of your last response.

I keep weekly backups via TrueImage and had to have this machine working so I just kept rolling back until everything was working correctly and now everything is good with a rollback from mid November. I don't know what the problem was but it's working great again.

I can verify that DOpus has no problem running side by side with with the programs I listed in my first post as it's doing it now. Even the Ace Utilities reg cleaner.

Maybe I had a corrupt Windows file or something, I don't know.

Thank you for your true concern and help. You are an asset to these forums and it is very much appreciated.