Can't set default program to open files

Just installed Opus on a new SurfaceGO 64bit with Win10 home edition. When I double click an excel file it asks me how I want to open the file and I say use Excel and always use it. But it does not remember. Every excel file I click on the same box comes up. I have tried a Word doc and that is ok. PPT also will not remember. The machine came with Windows defender and it keeps throwing up messages about blocking controlled folder access. So I went in Windows Defender and turned off real time protection and also controlled folder access control. That made no difference. Any ideas?

  1. Does the same happen in File Explorer, or only in Opus?

    If if works in Explorer, does it then start working in Opus afterwards, or still the same?

  2. Is this happening with Opus 12.9.x or an older version?

  3. If it is only not working in Opus, and Opus is up to date:

    • Please go to Settings > File Types
    • Then select File > Diagnostic from the top-left
    • Set the extension to the one you're double-clicking (e.g. xls or xlsx) and click OK.
    • A zip file will be generated on your desktop. Please attach it in reply here.

    On the other hand, if it's not working in Explorer either then I'd recommend doing a repair on the Office install, which will probably fix things.

Thanx for quick reply.
Explorer works fine; Opus does not. I have the current 12.9 version. I attached the file you requested.

I may have a problem install of win10 home on this brand new Surface GO. I am going to the store tomorrow. The other problem I find is that if I right click on a program icon on the task bar, such as word, that brings up the Recents. If I click on one of those recents it is not found; i.e. does not open. But if I open Word and click on File, and that brings up the options and the Recents, and find the file there and click on it, it works. I have also turned off the Tablet mode since I read one post suggesting that may cause a problem. It made no difference.
Any suggestions are welcome. (35.4 KB)

There's no .xlsx file type in your registry at all, which is why Opus isn't finding the right double-click application.

HKEY_CLASSES_ROOT\.xlsx\ -- Does not exist

It looks like you're using the Windows Store version of Office so I can't send you the registry settings from my machine as they'll be different.

Try repairing or reinstalling Office and I would expect that to fix things.

Thank you again. As I said, I am going to the store tomorrow. I didn't know there were different versions of Win10. It came installed as the S version and then they switched it to the standard Home Version. I will enquire. However, if as you say, that key does not exist in the registry, does it make sense that Explorer knows which is the correct file type to use? Also, I am not at that PC now, but of the programs, Word, PowerPoint, and Excel, it does handle Word correctly from Opus, but fails on PPT in the same way as it fails for Excel. I will let you know.

Explorer has a second location for extension -> program mappings (in fact, there are a lot of them, Microsoft keep adding more and more) which it'll use even if the main file type doesn't exist.

Opus looks in that second location as well, but only after checking if the file type exists. Explorer is a bit more forgiving or missing data in this case.

If you're still stuck after visiting the store, get in touch again in this thread and I can make some suggestions that will make Opus override its own double-click settings for those types of files. But it sounds like that or similar problems are also affecting other things, so if they can repair things in a better way I would go with that first. Then hopefully the recent lists off the taskbar will also work again.

Turned out the MS store staff had screwed up. They hadn't installed my copy of office 2016 but instead I just had the office apps. I had not previously known apps vs programs. So that is fixed and solved both problems I had asked you about.

I have another issue and this is not necessarily an opus issue and you may not want to take the time, but let me ask.

I do not want to use OneDrive as my primary storage but that is the way this PC is set up. When I look at Desktop/libraries/documents all of those docs are actually found under c\users\eberg\onedrive\documents. If I move any one of those folds to c\users\eberg\Documents it works in that location, but does not show up under Desktop/libraries/documents.

When I click on the documents folder under OneDrive, select properties, and try to change its location to c\users\eberg\documents by deleting OneDrive from the path name, and select apply, it asks if I want to move all of the files from the old to new location. I say yes and it says

“Can’t move the folder because there is a folder in the same location that can’t be redirected.”

I thought of first deleting the Documents folder in c\users\eberg\Documents but am afraid to hose things up.

Can you tell me how to go about getting my main folder location to be in eberg for my docs and pictures. The Videos and Music folders appear to be ok.

Right-click the Documents library (under Libraries) and choose Properties.

From there you can choose which folder(s) are included in the library, and which is the library's default folder for saving new files.

Thank you. I continue to appreciate your helpfulness over the years.

1 Like