Clicking PDFs: "Encoding that makes document readable"

When I open a pdf file within opus and close it again as well as opus, i get an error that states that I must select a encoding that makes the document readable, when I close that window, word is openened without any blank sheet and I close windows. This problem occurs if I just open the pdf file (which by itself is completly normal) and or select a page to be printed, it happens if I open de pdf file with adobe reader or select to open it with Acrobat XI pro, I use keyscrambler software but if I switch that off it does not make a difference, however when I perfom the previous described procedure with windows explorer none of these problems occur everything works normal, I had this problem for over a year and always thought it was a word problem so I deinstalled office and reinstalled it with the same result, I also deinstalled opus and reinstalled it witht no improvement at all.

What could be the problem, thanks MIcha (1.1 MB)

The messages in your screenshots come from Word, not Opus or Acrobat.

Opening PDFs in Word doesn't really make sense, at least as the default action, since Word isn't a PDF editor. Word will prompt you to convert the document into its own format.

Try assigning Adobe Reader (or another PDF viewer) as the default handler for PDF files, via the Open With menu.

Make sure the viewer pane is not open either, as that could be confusing things by opening the file in two things at once, which might mean we're diagnosing the wrong problem.

No, I open the PDF file in Opus (doubleclick on the file) and then the PDF file opens, when I close the pdf file then the Word message appears for me to select a language to make the document readable. (So the PDF file is now closed), when I close the message , then word opens without anything (not a blank page) and I have to close word (which was not open in the first place). Adobe reader is the default handler to open files (else I cannot get a preview of the content, if i use adobe acrobat),

And you might be right because after reading you reply I do notice that the correct problem as described above does NOT appear when the viewer pane is closed (which in my setup is always open)

That means it's happening when you select the file with the viewer pane open. Double-clicking the file has nothing to do with it in that case.

It sounds like you have added .PDF to the list of extensions the Word preview handler tries to display, which will not work. PDF should be assigned to a PDF viewer, not to the Word viewer.

Neither viewer is actually part of Opus, but you can use Opus to configure which extensions go to which viewers by going to Preferences / Viewer / Plugins, selecting the ActiveX + Preview + Office + Web plugin and clicking Configure.

the configuration you suggest, was already in place (129.9 KB)

If you add images directly to your posts they'll appear as part of the message, without making people download and open zips to see them.

The screenshot of the Opus viewer plugins list doesn't show which extensions are assigned to which third-party viewers.

You need to select the ActiveX + Preview + Office + Web plugin and click Configure. That will open another window listing third-party viewers and the extensions assigned to them.

I did as you told, there was an PDF assigned to it, I deselected it, saved it and restarted. But the result is the same

So it wasn't assigned to Word there? The Adobe PDF viewer can be left enabled, and won't be what was causing Word dialogs to appear, unless your registry data is seriously hosed and has the Adobe PDF registry data pointing to Word's DLLs instead of Adobe's.

Just to confirm, does this problem happen as soon as you click on a PDF file to display it in the viewer?

What does the viewer in File Explorer do with PDF files?

Have you tried reinstalling Adobe Reader? That would correct its registry settings if they are incorrect.

After I have deselected the checkbox (it was previous assigned), now it seems to work without a problem, however in the viewer i cannot view the pdf file, I just get the data

I'm confused. Didn't you say you did that before and still saw the message?

Please answer the questions in my previous post.

when PDF files in ActiveX + Preview + Office + Web configuration was activated, I could read each pdf file in the viewer but got the message that there was something wrong with the encoding and when I closed that message WORD opened. Since I deseleted PDF files in ActiveX + Preview + Office + Web, I do not get the errror messages nor does WORD start up but in the viewer of DOPUS the PDF file is unreadable

Something is wrong with the Adobe PDF viewer in that case, since it seems Word has hooked into it in some way from what you've saying. I've never heard of that happening before.

The questions I asked are still unanswered. Please answer them, as they will help understand what's going on.

no the problem does not occur in the explorer viewer i can see everything fine

Just to confirm, does this problem happen as soon as you click on a PDF file to display it in the viewer?
Yes it happens as soon as I click on a pdf file to display in the pdf viewer (not now anymore because i have unchecked the PDF file in ActiveX + Preview + Office + Web but now the file are unreadable,

So i will deinstall the acrobat reader and let you know

Don't uninstall/deinstall it. Try reinstalling it.

Using Open With to set Adobe Reader as the default PDF software may also fix it. It sounds the same as this problem:

I deinstalled Adobe Reader, reinstalled it, checkmarked the PDF box in ActiveX + Preview + Office + Web, and I do not get the errormessgages anymore, but in dopus viewer the pdf files are still unreadble is shown in the previous mail shot, in the explorer preview everything read normal.

Have you tried Open With > Choose Default Program > Adobe Reader?

it is solved I alsoe adobe pdf for vista under ActiveX + Preview + Office + Web and now it works, so the problem was somewhere in adobe reader, but it is solved now, thanks


1 Like