Clipboard COPYNAMES doesn't work anymore with current folder

I used till now a lister context menu which allowed me to copy to clipboard the current folder name or the current folder path. They used respectively those commands:
Clipboard COPYNAMES=path,nopaths
Clipboard COPYNAMES=path
But since DOpus version, something has changed and it does not copy anything now. Is it normal?
I tried with the default configuration and it does not work also.

I suppose the forum is a better place for such question, am I correct?
I am not sure, maybe filling a support request about a program anomaly would be better.

Those commands would never have copied the current folder path to the clipboard, in any version. Instead, they copy the paths of the selected files/folders to the clipboard.

For the command that you want, see Copy the current path to the clipboard.

See also: Commands to copy selected filenames to the clipboard.

Many thanks for the links.
I saw from one of them the "copy current path" is available in DOpus 10 by default lol . Now I remember, I used such command before for copying source and I looked for a way to copy the "current" folder name. Finally I found that using the command from my first post worked so I edited also the command for source path...
I needed such button mainly because the context menu from folder tabs and file display border ceases to work randomly since few versions (or maybe since version 10). Now there is still breadcrumbs location field that seems to always work for this task...I didn't think about it before but I hope it has not the same issue as the other area.

Turn on Preferences / Folder Tabs / Options / Treat tab label as folder when dragged or right-clicked :slight_smile:

It is on but as I said, it ceases to work randomly :stuck_out_tongue:
I suspect it has to do with my specific configuration since no one complained about that and the problem concerns my desktop and my laptop. One day I will try probably to isolate it but it is difficult because I have no idea where it comes from. In fact, the problem seems to appear and disappear randomly. Now it works normally but I am sure that in few minutes/hours I will try to right click on folder tabs or the file display border and nothing will happen, no menu, nothing.

Next time it stops working, try the FAQ on context menu problems to see if its debug steps reveal anything.

Ok, I will read that but my problem does not concern the whole context menu. I mean, the problem is located only on folder context menu from folder tabs or the file display border. The folder context menu works without any issue on the file display or folder tree. But I will try the FAQ :slight_smile:

Oh and I forgot, I always hide Windows context menu using Preferences/Miscellaneous/Windows Integration/Hide Windows items on file context menus (shift overrides). But I use Filetype CONTEXTMENU CONTEXTOPTIONS=windowsonly in a sub-menu from all files and folders context menu. I suppose that cancels the "Hide Windows items on file context menus" option.

I do that as well. :slight_smile:

I probably took it from one of your post :stuck_out_tongue:
Just for info, my problem is gone for now. The only real change I have done is just replacing the commands from my first post to what you suggested me. I hope it will never come back :astonished: