GP SoftwareTwitter
Opus FAQsManualCommandsObjects

CMD Here Completion Character

I've used this context menu action for folders for years ("C:\Windows\System32\cmd.exe" /f:on /s /k pushd "%1"). It works fine, but doesn't honor the CompletionChar key, with a value for the tab key in the registry under HKCU & HKLM \Software\Microsoft\Command Processor. Anyone have any ideas? The default control-D works fine.

Tab is the default isn't it? Always has been as far as I know.

Apologies for posting this in Opus support--I thought it was an Opus issue since it worked outside of Opus. I was causing the issue by invoking the /f parameter. Mystery solved. If you use the /f switch to turn on command completion, Crtl-F is used for file name completion and Ctrl-D is used for directory completion. If you enable it in the registry and change it to hex 09 instead of the default 40 the tab key works. https://www.online-tech-tips.com/computer-tips/how-to-turn-on-auto-complete-in-the-command-prompt

Interesting! You learn something new every day :slight_smile: