Conflict with Toshiba laptop media keys

I remember the same bug in DO10 beta pre-release but I find nothing in forum (DO10 beta section has been deleted).

There is a conflict with some media keys in my laptop (Toshiba Satellite).

Play/pause key flashes Lister (Title bar is highlight and mouse cursor change briefly).
In dual mode, if i press volume down media key in my laptop, Lister jump between source/destination. In single mode, focus jump to tree.

Of course, no shortcut has been configured for these multimedia keys.

The only time when Opus intercepts the standard Play/Pause media key is when certain viewer plugins are active (e.g. it'll play/pause the Animated GIF plugin).

Other than that, the key is ignored by Opus and should be passed through to other programs running to see if they want to handle it, or ultimately launch the system media player (or whatever the OS or keyboard drivers are configured to run).

Toshiba's keyboard software may not be sending the standard Play?Pause media key event when the key is pushed, however. In that case, all bets are off, and their keyboard driver could be doing just about anything. (Some look at the active program(s) and send different keypresses, for example.)

I just checked using the Microsoft IntelliType drivers and an MS keyboard on Win7x64 and it behaves as I described.

Googling for toshiba play pause button suggests Toshiba are doing something non-standard, with the button not working properly in lots of software that supports the key, but it can be configured in some way.

I have a similar experience with Opus 11 grabbing my Lenovo T420's volume keys. If I'm in dual view mode, the volume-DOWN key cycles which file display is active. If I'm in single view mode, then the volume-DOWN key first switches input focus to the Search field on the Menu toolbar, then back to the file display, THEN starts lowering the volume.

I disabled every viewer plugin in Prefs and still see the same behavior. I don't recall ever seeing the same thing in v10.

Plenty of threads about Lenovo's media keys not working out there as well.

If you've got access to the Spy++ tool that comes with Visual Studio, you could use that to see which keypresses are being delivered to the Opus windows. My guess is they are sending something other than the standard media key (which works without issues under Microsoft's keyboard drivers, as well as Dell's laptop media keys at least last time I used my laptop).

I have download Spy++8.
How I can do that Leo ?

You'd need a 64-bit version unless you're using a 32-bit OS. (That 32-bit version of Spy++ does not look like it is legally distributed, either, so I've removed the link.)

Does the Play/Pause button work in Windows Media Player? Ensuring that is a good first step as from the sound of many of the articles the button doesn't work properly at all in some cases.

Oh sorry :frowning:

Yes, if Windows Media Player is open (even in background), play/pause button work.

So with WMP in the background and Opus as the active window, the Play/Pause key no longer does strange things to Opus?

That's definitely the keyboard drivers doing something wrong because the active window should get the first chance to handle a media key, and the only way for WMP to see it should be if Opus ignores it, but what you're seeing is Opus ignoring the key if WMP is in the background and handling the key if WMP isn't running.

(Only way I can think of that makes sense of that is if an Opus global hotkey is being triggered if WMP doesn't handle the key, but that would only happen if you had a global hotkey defined which triggers the event you are seeing.

Everything points to the keyboard drivers doing something wrong, which is backed up by all the threads on the net about getting them to work properly.

Actually, the Play/Pause behaviour sounds OK. The titlebar and mouse cursor change just indicate a program is being launched in response to the key, but then it exits and focus returns to Opus. (The key should launch the default media player, and presumably whatever is launching is misconfigured and just exits.)

Do you not see something similar in other programs? (And why is that a problem anyway?)

The volume up/down key, on the other hand, seems wrong. That's like it is generating a Tab keypress. What happens in other apps, and does it make a difference to have WMP in the background playing music?

First, I'm NOT excusing Lenovo from doing something funky or inappropriate. But:

I haven't seen this same behavior in any other app, including Opus 10. I just re-tested with Opus 10 from USB key on the same laptop and on the off-chance that I just hadn't noticed this over the last several years running v10 normally (;-)). But no, it doesn't happen anymore when I roll back to v10. I thought for a minute maybe something about the media key related hotkeys might be involved so I deleted those in v11, but it made no difference either. I thought I recalled there being a similar key press issue in early v10 beta's actually... and that it got fixed before release?

Having WMP open doesn't change the behavior one way or another. When Opus is in focus, the Vol DOWN key still causes the file displays to switch back in forth in focus in dual-mode. In single mode, if I keep pressing the Vol DOWN key, the input focus first changes from file display to the Search field, then to the Folder Tree, and then the volume finally starts to decrease. I tried using spy++ v8.0 but it doesn't seem to be logging any messages for the Opus window at all. Don't know if I'm using it wrong, or if the 32bit version can't log 64bit app messages or something...

I don't remember any media key issues in the Opus 10 betas, but I might have forgotten something. There was an issue with hotkeys in general when using French and some other languages, but that's long been fixed and was very different to this.

Here's what happens when I push the volume keys with the Microsoft keyboard + drivers:

Thanks for the video of it working properly, but I believed you without the evidence :slight_smile:.

Here's mine: ... ZHA70NudfY

What happens if you bind hotkeys to Tab, Shift + Tab and Ctrl + Tab so they all run Help ABOUT or similar? Does it trigger them?

Clever, but no change unfortunately. I also made those hotkeys system-wide just to see if ANYthing seemed to be sending those key strokes anywhere. The only time the Opus help window popped up was when I hit the tab key in opera while posting this message.


Only volume down key cause problem (play/pause and volume up are ok).
You can see my capture bellow. Note that one tap switch source/dest, hold key switch too then top/bottom Lister become source. ... %20key.wmv

Hopefully these issues will be fixed in the next update.

I've still not been able to reproduce them on either of my machines, but I was able to reproduce a very similar problem with the Volume Down key on my laptop. That's fixed now, and hopefully the underlying issue was the same as for what you're seeing in this thread.

Confirmed that problem is solved in 11.1 Beta 3.