Control Panel Icons Missing After Installation

Hi. Just installed DOpus V8.2.2.4 (and this has happened with previous versions, didn't know the software that did it until after this installation (on a fresh Windows installation)) and most of the control panel icons are gone (via Start Menu/Control Panel).

On 5 or so of them are left in there, but none of the useful ones.

I rebooted Windows after updating my display drivers and the Control Panel was intact. Installed DOpus and they disappeared.

Is there a way to prevent this, or get them back?

System Specs:
Windows X64
2 gig RAM
ATI x1900xt Gfx Card
Soundblaster X-Fi Sound Card
+other stuff.

I was determined to find out which software cleared my control panel, so I looked at it after installing every software/update after installing Windows. Didn't happen until I installed DOpus.

I think there may be a way to get them back from my Windows CD, but can't remember.

Any help appreciated.


I suspect the problem is becuase Opus is a 32-bit process and on Win64 it cannot load/see the 64-bit Control Panel applets.

To solve the problem, make sure Explorer handles Control Panel instead of Opus. Go to Preferences / Miscellaneous / Explorer Replacement and ensure, through whichever combination of options best suits you, that Opus is not set to handle the Control Panel folder.

Setting it to handle only file system folders, or to handle all folders except Control Panel are two ways of doing this.

Now when you open Control Panel via the start menu it will open in Explorer instead. If you open Control Panel via an Opus lister (e.g. by double-clicking it within My Computer) then you'll still get the same problem, but viewing the folder via the start menu or Explorer should be fine.

Thanks, it kind of works.

I changed the setting as suggested, and have all folders except for Control Panel and Recycle Bin being controlled by DOpus.

However, when I go to Control Panel via Start Menu it opens in an Explorer window, but icons are missing.

But, if I open an Explorer window first via the Start Menu, and then open the Control Panel I can view it normally.

A partial success, but at least I can view all my icons this way.


Does that still happen if you completely disable Opus's Explorer Replacement mode? ("Don't Replace Explorer" option in Preferences.)

If so Opus is completely out of the picture and the problem must be due to something else.

Just tried it, and no.

If I disable Explorer replacement completely, clicking on Control Panel opens successfully, as would be expected.

Put DOpus back to 'for all but....' (where Control Panel is stated) it goes back to only showing 5 icons or so (!).

Are there two versions of Explorer on Win64? Maybe Opus is causing the 32-bit one to be launched when it's handling some folders but not all, or the 64-bit version behaves differently if launched via a 32-bit process.

I'm not sure how the Control Panel redirect works when Opus handles some folders but not all...

Best thing to do is file a bug report to GPSoft:

I doubt they'll be able to make control panel within Opus look right until there's a specific 64-bit version of Opus but they should be able to make the start menu work again without too much hassle if it's the sort of thing I'm guessing it is. (I am just guessing though!)

As a workaround you could set the start menu to show the control panel as a sub-menu and then you never need to open a control panel window.

Control Panel as a menu - good idea! That works :slight_smile:.

Will submit a bug report just to let them know of the problem, just in case.