GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Convert graphics files locking up (due to TeamViewer)

Recently (some time in v12), Dopus has been unable to convert images for me. Worked perfectly up until then, and still works fine in an older version that I still have installed.

Pretty basic stuff but the sort of thing I always use Dopus for as it's always done this stuff simply and well.

Are you using TeamViewer?

Yes Teamviewer 12.

Slightly off topic, but recently i was trying to convert images using the same dialog. As it seemed, it work only, when i used the same option as in the image above, conversion to the destination folder. When i unchecked that box, the conversion didn't really work, as the file size didn't change, using the same settings (80%, i think). So the files didn't get replaced by the smaller version.

Maybe this is related?

I don't think it's related. This thread is about the whole dialog locking up, which is caused by Team Viewer injecting a DLL into Opus which goes wrong for some reason.

If you convert in-place and the file size doesn't change, it's probably because the image converter avoids re-compressing JPEGs (since that reduces quality and is irreversible) unless it really needs to, or unless you add the argument to the thing which launches the converter which forces it to recompress them (for when your aim is to make the filesize smaller without resizing or rotating the image, and smaller size at reduced quality is what you want).

Ok, i wasn't sure. Feel free to clip this part, since it's not even a bug.

I think it's a bug.

What abr was talking about isn't a bug.

What the main thread is about is indeed a bug. A bug in Team Viewer.

Can you provide some more information? So far the only comment was are you using TeamViewer.

The info is in the thread I linked to when making that comment. The theory that TeamViewer was involved came from a debug dump in that thread, and seems to be confirmed by everyone who has the problem also having TeamViewer installed:

I have tried with TeamViewer 13 (Beta) and can confirm that the problem persists. On my system it only occurs if TeamViewer is actually running rather than just being installed.

Please report this to the makers of TeamViewer.

Done.

1 Like