"Copy all NTFS data streams" doesn't work from collections

I'm using ADS a lot. The setting "Copy all NTFS data streams" has been working extremely reliable for me, except 1 scenario:

When a file with ADS streams is copied from within a collection to another location, the ADS is not copied. I've tested copying the file from same drive to different directory or different drive, neither one works. Otherwise it's bulletproof.

Attached is a file with stored NTFS stream; the stream name is "MTHash_SHA1".
The file inside has 1 ADS stream.rar (309 Bytes)

Thanks for spotting and reporting this! We have fixed it for the next update.

1 Like

Hi @Leo @Jon
Just downloaded 12.24.1. Unfortunately "copying ADS out of a collection" does not copy all streams. The file attached in the RAR above with 1 stream (MTHash_SHA1) was not copied correctly. Interestingly another file with also 1 stream (MExt_MediaInfo) was copied correctly but only once. When I deleted the file and re-copied it out of the collection, it was not copied. When I delete all and redo the copy, no stream is copied.
It also seems fsUtil.GetADSNames() has a small regression. It does not list 1 stream (MExt_MediaInfo) at all.

Thanks, we'll take a look. I can confirm it's not working correctly in the current beta.

The intermittent behavior you're seeing may be due to Windows "tunnelling" behavior where attributes and ADS from an old file can be brought back to a new file if it's created with the same name and path quickly enough.

It seems to work OK with multiple streams:

How are you calling it?

1 Like

Great. Much appreciated!

Indeed. It was a bug in my logic. Sorry for the noise :slight_smile:

1 Like

This should fix things:

EDIT: Proper beta / installer available now: Directory Opus 12.24.2 (Beta)

We'll put this fix into the next beta with a proper installer, of course, but I wanted to get you a test version quicker.

1 Like

Amazing! Just amazing!
And yes it works just as expected! I also tried to provoke this tunneling behavior, using 5-6 quick copy-delete-recopy back to back. No problem so far.
You guys never cease to amaze me/us!


Thanks for the quick feedback!

1 Like