Copy Dropbox Link Shortcut - stopped working

Hey all

I was using this shortcode to create a keyboard shortcut, for copying the public dropbox link of a file:
ContextMenu ITEMMODE LABEL "Copy Dropbox link"

After updating to the latest version, it stopped working.

Any ideas?

Thank you in advance

Can't reproduce on my system. Tried successfully with Dropbox 143.4.4161 and Opus 12.26.3.

But Dropbox has been a bit flaky in the past weeks and wanted to be restarted on several occasions for no apparent reason. So maybe try with a fresh Dropbox installation before you dig any deeper.

Is there still an item in the menu with that label? If Dropbox isn’t adding it or has changed the label then the command you’re using won’t find it.

The shortcut is still there in the context menu.

When I right click and do it manually on a file/folder - it works,
only via the shortcut it doesn't work

Which versions did you update from and to, between it working and not working?

I can't tell which version I had before, but now I am working with 12.26 build 8006

Try selecting the file and running ContextMenu SHOWCMDS, then use the UI that opens to create the command for the menu. Does it give a different command to the one you're using now?

(With the file selected, you can run the command by typing a > and then typing/pasting the command into the lister. No need to create a toolbar button for it, unless you plan to use it a lot.)

When the UI opens with a list of commands, the "Copy Dropbox link" is not on it, maybe that's the issue.

When I actually right click it, it's there

Are you holding Shift when you right-click the file? Run ContextMenu SHOWCMDS SHIFT if that's the case.

Otherwise, it's possible DropBox have changed the way their context menu works in an update, such that it's no longer possible to run it programmatically via the normal method.

If you're on Windows 11, DropBox may have done that because of Microsoft's decision to introduce a new type of context menu handler in Windows 11 and relegate things that don't use it to a sub-menu in File Explorer. Which would also explain why it still works for people on Windows 10 (where the new type of context menu isn't needed, and wouldn't work, and so wouldn't be installed by DropBox).

No shift, just a regular rightclick. And windows 10

Thanks for letting me know, maybe they will change it again later on.

Hey there

I have an intersting update on this.
After updating to the new DOPUS version, the "copy to dropbox" command showed again and worked.

2 days later, it's not working anymore and not showing under "ContextMenu SHOWCMDS"

How strange

What can cause this?

Thanks in advance


Check it hasn't been added to Preferences / Miscellaneous / Advanced [Troubleshooting]: ignore_context_menus due to instability.

Other than that, there's nothing that would happen on the Opus side which would make a menu stop appearing 2 days after an update if no configuration has changed and you haven't gone to or from elevating dopus.exe when you launch it. Something on the dropbox side is more likely.