Copy paste filename as .txt

Am regularly doing the following action:

select a file (click on it)
F2 - copy the filename (without extention)
a file is created named Clipboard Text.txt
Paste (the name of the 1st selected file)

So there will be 2 files then

I wonder whether there is no easier way, a script that would create .txt files named after the selected files.


filetype new .txt newname "norename:{file|noext}.txt"

Thanks a lot!
That worked out fine.

I've got this as a menu item

filetype new .txt newname "norename:{file|noext}.txt"

One way or the other it doesn't work anymore.

Any suggestions?

The idea is that I select one (or more) file(s) - click on the menu item and .txt files are created
of the selected file(s).

Capture-03112017 075545

That seems to work fine here.

Are you sure the files aren't being created but hidden, either due to filters or sorting by something other than name?

Does "filetype new .txt" work on its own? If not the .txt filetype in the registry may be broken, which is easy to fix.

I am afraid it doesn't work. I changed the menu item to read just..

filetype new .txt

but frankly, I am not sure if it all okay the way I do it.

The other day Windows 10 tried to install the 1709 update, which failed repeatedly (for reasons that are unclear to me, BSOD). So Windows restored the previous version. I believe I am not the only one facing a failing update.

It could be (just a wild guess) it has something to do with this update.

Anyway, the instruction in my first post, when you were to select files and use this 'instructions', will then be new files created with .txt extension, right under the selected files, at your end ?

oh btw I just restored a Opus backup, to see if that one would be, but .. bad luck.. it doesn't work.

a day later - just to let you know.

The registry entry

kept up showing a different (previously used) editor than the one I use for .txt files and have associated with.

The 'previous' editor, I uninstalled using an advanced uninstaller - removing registry entries, etc.
Folders that referred to the previous editor were removed, but the moment I re-assigned .txt to my current editor, the previous one showed up.
I had to 'crawl' thru the registry removing all references.

Anyway, copy paste filename as .txt now works again.


We've made some changes in the next version that should keep the New Text Document handler working in Opus even when the registry data is trashed, since this has caused a few people problems over the years.

(Incorrect registry data will still cause problems in Explorer, so if you find out what caused that it's still worth complaining to whoever is responsible, but it will cause less of a problem in Opus.)

Thanks Leo.

BTW - please do note the last line of my earlier post: I eventually fixed the matter after removing quite a number of incorrect registry settings, that is to say, registry settings with reference to an editor that did not exist anymore on my system.
After re-assigning .txt to the correct editor, the editor actually in use, the matter was fixed and Opus created .txt files the way I was used to.