Copying folder not working

I have been having problem coping files since I ever used DOpus, which is killing the overall experience.
I decided to reinstall the app scratch (tried both 12.30 and 12.30.1 Beta) with hope to make it better but this won't help.

See below animation where:

I can copy a file with drag and drop
I cannot copy a folder in the same manner
I can use the toolbar copy for the folder
The same applies with CTRL+C/V

I saw past posts from years ago with similar issue but did not find a solution.
Thanks for your support.

Did you try uninstalling, then reinstalling, to reset your config?

The most likely thing is that the folder drag and drop events have been changed to something that doesn’t work (or doesn’t copy, at least).

Yes I did fully uninstall, rebooted, the reinstalled. The config was reset (all styles back to default).

I am not clear why copying file is OK but folder is KO. This should be the same call right?
Is there any option to disable to try alternate copy "handlers"?

They can potentially run different actions (although that should not happen with the default config).

Does copying the same folder by selecting it and clicking the Copy Files button at the top left of the toolbars work?

Are you able to copy the same folder to the same place using drag & drop in File Explorer?

Yes the "copy files button" works (also visible from my original video, the last performed action).
Yes about the copy in the regular windows explorer. No problem.
Just tried again in DOpus and still the same, nothing is happening.

Is there a nuance of "handler" when copying a folder versus a file? One is working but not the other one.
Same for CTRL+C/CTRL+V

If both drag & drop and Ctrl-C/V are not working, and only for folders, while also working for files, then my guess is there's a clipboard monitoring tool or antivirus / anti-ransomware or similar installed which is interfering with things.

Drag & drop and Ctrl-C/V both use the Windows clipboard APIs, while the Copy Files button does not.

I tried an alternate free file manager for the sake of testing how it does; I pickedup and they have no problem copy/pasting a folder. I notice though that they run their own "copy manager" even for CtrlC+V, rather than the Windows "silent" copy mechanism. Can I replicate this with DOpus? (hope so...)

That doesn't tell us much since we already know other methods of copying work (File Explorer and as well as the Copy Files button in Opus).

  1. Which antivirus etc. are you using? Have you tried disabling them?

  2. Do you have any clipboard monitoring/history tools installed?

  3. A third possibility is a shell extension. Use ShellExView 64-bit, sort by the Type column, and see if there are any Copy Hook Handler, Drag & Drop Handler, or Drop Handler extensions installed. If there are, right-click them, disable them, then reboot to see if that makes a difference. They can be re-enabled in the same way.

So happy to report that the #3 point you mentioned helped out.
I cleared out many outdated ShellExtension, which also probably removed lot of clutter out of my system.
Thanks a lot!

1 Like

Glad it's working now!

If you can work out which extension it was, we can investigate in more detail.

I cleared too many at once, can't point point the culprit.
Benefit being that my system is way better now in general :slight_smile: