GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Crash opening context menu on music files

Yes i'll do that immediatly

video sent via private message, thanks again for everything !

Many thanks for the excellent videos!

I've tried right-clicking the same files on a couple of machines without any issues, so my guess is there's something 3rd party involved, or something in your config.

Trying the config is something we can do easily, so let's look at that first.

menu

The context menu looks like it has some custom items in it. Maybe one of those is triggering a bug when these file types are right-clicked.


Here's a quick way to send the relevant info:

  • In Opus, go to Settings > File Types.
  • At the top-left of the dialog, open the File menu and choose Diagnostic.
  • Type the extension and click OK.
    image

That will place a zip file on your desktop with the file type info about that file, including any custom context menu items added in Opus.

Could you do that for the mid and mp3 extensions and send us the two zips?


If you want to, a config backup might also be worth a try (Settings > Backup & Restore).

Note that (unlike the file type diagonostic), the config backup will include things like FTP passwords and recently accessed paths. You can rename the extension to .zip to look inside it and edit/delete anything you don't want to send us. The FTP sites shouldn't be relevant so deleting ConfigFiles/ftp.ocx and ftpdef.oxc from the zip is a quick way to deal with those.

Of course, please send that via private message if you want to sent it at all, just in case there's anything sensitive still in the file.

Hi Leo thanks a lot for the help, the custom "redo" that we see at the bottom was a script that i found here

i never used it except the day i installed it, it stayed there since then. i'm trying to remove it to see if it's what crash the files. i removed it from the list of script in parameters, but it didn't changed anything but it's still there in the menu visually, i'll try to remove it (don't remember how to do it lol, must read again the topic about it) and if it still crash, i'll follow your advice. i'm a bit worried about all the personnal info, so i'll investigate the file before sending them to you in private message. thanks for the help !

Hi again, just sent you 3 messages, including the requested file (file type + backup file, hope it will be of any help ;).

Thanks again !

Many thanks for the file type details and config backup.

I tried with your config and still don't get a crash. Whatever is happening is quite strange.

Would it be possible to generate a Process Monitor log of the time leading up to and just after the crash?

A log with both registry + filesystem (the first two icons shown in that post's example) turned on might reveal what's happening at the time of the crash, and which components or code within Opus is involved.

Another thing to check is if this started happening with 12.13 and might be due to a change in Opus, or if it's more likely due to a change in something else. The 12.12.x installers can be found in this thread about an issue in 12.13 that a couple of people are seeing which we're also trying to track down:

Hi leo, thanks to have taken the time to investigate. as said in my PM, i can't reproduce anymore since yesterday night the crash... but i did 4 things yesterday before sending you the files.

  • i reinstalled dbpoweramp
  • i reinstalled the vanbasco midifile player
  • i removed the redo script but you certainly noticed that there are still some code present in the config file i saw it when i reviewed each file for personnal information.
  • a windows update has been sent by microsoft yesterday (certainly the usual tuesday patch day)

so i'll wait until i can reproduce again the crash (maybe it's gone forever ?) , but yes, i confirm that the issue started to be there when i installed the 12.13 ! good luck, and i'll come back as soon as the crash will be back and will do what you ask ! thanks for everything !

Edit : Forgot to tell i uninstalled a software that i was using, called https://lockhunter.com/

1 Like

OK, thank you! Maybe it was caused by something else that's now fixed. If not, and it comes back, let us know. There are a couple of other things that may be worth trying in that eventuality, and (for the issue in the other thread) we're currently going through all the code-changes in these versions to work out more tests to run or potential causes.

Whether it was something else & now fixed or just not happening temporarily and comes back, many thanks for your time and help investigating this!

1 Like

crash is back :frowning: so i'll follow your precedure, will do it tomorrw , thanks !!

Hi again leo,

I installed each version of DO before the 12.13 until i find when it's stop crashing (must try more, but each version were making the crash and it stopped immediatly with the 12.12

12.13 = crash
12.12.4 = crash
12.12.3 = crash
12.12.2 = crash
12.12.1 = Crash
12.12 = NO CRASH !!!!!! Ahhhhhhhh Finally !! lol

does this help ? just noticed the release of the 12.14 don't know if i must try ? lol. (at worst i can re install the 12.12), i hope a solution will be find, don't want to stay blocked at the 12.12 :slight_smile: (impatient for a DO 13 release if it's planned soon :wink: ).

Is it definitely 12.12 that fixes things and not something else... e.g. the 12.12 installer requires a reboot while the beta installers don't, so if the problem only happens after the machine is on for a while it might not show up for a while with the 12.12 installer?

Hi again, i confirm that

  1. at first, i was on 12.13 = crash almost all the time.
  2. i install 12.4 = crash, 12.3 .2 .1 , crash, then i install (always without any reboot) 12.12 = no more crash.
  3. i rebooted 2 or 3 hours ago, and under 12.12 i still have no crash at all. i'm launching right now while typing the installation of 12.14 to see if crash happens or not. maybe the fact to reinstall the 12.12 and then going directly to 12.14 could be the solution ? answer in few seconds, and tomorrow confirmation as it's very late here 2:53am)

ahah.. i confirm the crash is back with 12.14... (immediatly just by right clicking on my beloved .mid file.

i'm installing again the 12.12 version (without rebooting) right now and... (drum roll).. and no crash at all lol...
i can if you want make a full video showing all this.
so...
12.14 + 12.13 + 12.12.4 + 12.12.3 + 12.12.2 + 12.12.1 = crash
12.12 = no crash.

Have any of the versions managed to generate a crash dump since you started trying them?

I'll have another look tomorrow at changes between 12.12 and 12.12.1 to see if anything looks like it might be involved.

Unfortunatly no, no crash dump :frowning:

Thanks !

If you turn off Preferences / File Displays / Options / Enable file InfoTips in... entirely, do you still see the problem?

Please also update Notepad++. From the ProcMon logs, you have a version of its shell extension from 2014 installed which is known to cause issues.

(For some reason that version is still very common, although every time I ask why so many people have such an old version of a free tool installed they stop replying, so it is still a mystery to me! :slight_smile: I figure it must be bundled by something else, or something.)

I think it's an issue with the update at notepad++, i updated it the last time i used it one week ago, i'll do that immediatly. but a friend of mine (programmer) suggested me an another software instead of notepad++, so i can uninstall it if needed. i try the turn off info immediatly, but first, upgrading again to the 12.14 before ahha :slight_smile: thanks for the help, i do that immmediatly.

my notepad++ is version 7.5.9 from 14th october 2018. weird ! lol. the shell extention update must be somewhere else in the software, i check that immediatly.

It's possible the shell extension hasn't needed an update for a while, but the latest Notepad++ looks like its shell extension DLL is dated 2019, so there must be a slightly newer version at least.

i'm very sorry to tell that
after uninstalling notepad++
did a cc cleaner after it
and turned off enable file info tips

crash still happen (on .mid file and .mp3) lol :smiley:

good night (late in france), i'll come back tomorrow :smiley: ahh back to 12.12 :frowning:

edit: just did a second reboot, no more crash for now !!! (with tips enabled or disabled). can't reproduce the crash for now (notepad++ fault ?). we'll see i'll do more test tomorrow. thanks again, good night (or day in australia :slight_smile: ).

1 Like