Crash right-clicking ~270 PDF files

I am trying to copy approx 250 pdf files from 1 directory to another. After selecting the files, when I right click to copy Opus hangs for approx 1 minute then crashes and restarts. The copy works fine with MS Explorer. I tried turning off Bullguard virus protection but still get the error. I am on V12.22 but had the issue with V12.21 as well.

Please see if any crash logs were created and submit them to us for analysis if so.

Crashes when right-clicking files are usually caused by bugs in shell extensions which other software installs to add things to the context menus.

Since you're right-clicking PDF files and a lot of PDF software is poorly written (for some reason), I'd suspect an extension tied to one of the PDF tools.

Jon's suggestion (above) of sending any crash logs that were saved is still a good idea, as we can often use those to tell you which extension is crashing.

This guide can also be useful if you want to try tracking it down via other methods: Crash, exit or high CPU when right-clicking certain files

You can copy files without right-clicking them: Select them and then use the Copy Files button (near the top left of the window) with the destination folder in the second (destination) file display. Or use ctrl-c / ctrl-v to copy & paste. If that works then it confirms the issue is with the context menu, and probably a shell extension, and not with copying the files.

Hi Jon. No crash logs were created I'm afraid mate.

Hi Leo.
Using the Copy Files in the top left of the window work fine thanks. There are 273 PDF files (49.7 MB) are invoices generated by MYOB so they are all basically the same. The odd thing is if I select the first 269 files, right click works fine as does if I select the last 260 files, right click works as well. So to me it isn't an issue with 1 or 2 files, just when I select all 273. Ctrl C / Ctrl V works fine as well.
I replied to Jon re no crach logs were generated.

Try disabling any PDF-related shell extensions (instructions are in the guide I linked earlier) and then rebooting. My bet is the problem will stop then. If so, re-enable one at a time until the problem comes back, and you will then know the most likely cause.

Hi Leo. Will do thanks mate.