Crash: search with name matching and containing text

Thanks. I only have ONE Search Filter that contains .ini which seems to match with yours.


I removed the entry - same crash.

By the way - I installed a 64 bit filemanager called FMAN and it also does not crash on my machine when I run a search for *.ini and the text Roundline in the files.

I have reset Dopus to its defaults. For some reason only Dopus is crashing and the .ini extension is tied to the same Search Filter as yours. But, you cannot duplicate the issue. I guess we are stuck unless there is some sort of debug I could do within Dopus in order to catch what is happening behind the scenes?

If this is only me - then its fine. I love your product and if this helps your product become better I am willing to help. If this is isolated to me, and there is nothing else to be done, that is OK. Let me know.

I don't know if FMAN uses Ifilters or not.

Did you try removing the two .ini files I mentioned to see if you still get a crash then?

Only found one entry in Search Filters for .ini. I removed it and it still crashed. I Then put it back.

Is there a specific .ini file in the group of files I sent you wish me to delete? Apologies if I missed this.

At the top of this post:

By the way, when you zipped up the folder, did you use Opus to make the zip? If not, please try that in case something is killing the process if it tries to access certain files. (Seen that once or twice with privacy tools deciding a random file has personal data and being more suspicious of some exe files than others.)

Hi Leo - thanks for sticking with this.

  1. I removed those two .INI files, same result
  2. I did use Dopus to do the zipping

As a data point - XYplorer has a setting to use 64-bit Search Filters. I set this option, ran the search several times, no crash.

Haven't had a chance today, but we'll see if we can make a special test version that logs what is happening during the find operation to see if we can work out where it's going wrong.

Generating a Process Monitor log of the crash might reveal something as well, if you want to do that: