GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Crash when using Shift + Mouse Wheel

When I navigate fast between folders using Mouse Wheel and Shift Key Directory Opus is crashing quickly. Sometimes it is also starting new listers.

I discovered it when I wanted to test the mouse wheel function.

Please see if a crash log was created and submit it for us to look at if so.

Yes, I will look in the %Temp% Folder.

Thanks for sending the dump files.

It's not conclusive, but it looks like a crash caused by something hooking Opus (and other processes) and corrupting things. The crashes are in a number of different places and look fairly random, but are always while UI events are being processed.

Based on the DLLs loaded in the process, and what they do (and how they do it), could you try temporarily uninstalling PowerPro to see if the problem still happens then?

I uninstalled PowerPro and it still happens. I even reinstalled Windows and tried it on a fresh install. And it crushes merciless. I will send you the Minidump of the crash on a fresh install.

do you happen to have a logitech mouse and their setpoint software installed? i ask because i on yesterday i tried voluntarily to crash it (and DO crashed, logitech T400 wireless mouse + logitech setpoint app v.69.123, minidump file is still available if needed). today, with a different mouse nothing happens, no crash at all.

regards, Paolo

Thanks for trying that. That rules out PowerPro.

Please could you try this test version and let us know if the problem still happens:

http://leo.dopus.com/temp/DOpusInstall-MouseWheelTest.exe

I think I was able to finally reproduce the problem (have to scroll very fast, with a lot of folders in the history list), and made some changes which should prevent it.

@nexus.vi No I haven't. I think it has nothing to do with the mouse driver.

@Mr. Davidson Thank you. The version you uploaded is OK and it doesn't crash.

But I tested it already with version 11.19 and the inglorious 12.12 (Sally L. version) and there was no crash at all.

What I still want to tell is: There's a file called dopuslib.dll. It is very stubborn and can't be deleted. And it is used by other programs, too.

And when you want to reinstall another version you can't do it before you restart your computer.
But there is only one registry entry that has to be deleted: "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\PendingFileRenameOperations" and then you can reinstall DOpus without restart.

DOpus seems to be like a juggernaut.

Great, thanks for confirming!

Older versions of Opus needed a reboot. Newer installers don't and will simply rename the in-use DLL out of the way so it can be cleaned up next reboot.

There is no need to worry about the DLL or rebooting with current installers; only with old ones.