Default actions for file types not working


I was quite happy working with dopus while, from one day to another without any new program install or system change, your product began to behave quite strange:

double click never did the action defined for each file (for example, when doubleclicked a sound file instead of playing it just openened the app and nothing more). The actions were the ones defined by default,i.e., the system ones. Win explorer worked perfectly but dopus not. I also tried to define different actions for dopus but it did anything except what it was instructed to.

Finally I had to uninstall dopus, lose all my personal settings (which took me very long and hard to set) and in the way, don't know how and/or why, my eval expired .. great!

Tried to clean my system and reinstall but no way... No mention that I lost plenty of time.

Finally I asked for another eval and now everything is back and ok...But yesterday I already began to behave a similar nasty way ...

As Win xplorer works ok, I assume that the problem is within dopus.

I really like this software, but find very, very unpleasent that it "crashes" when I took so many time to configure it to work faster and properly.

Hope you can help me.

Best regards,


:opusicon: P.S.: BTW, the form for getting support for eval users does not work; should delete that message to be consistent:

"Evaluation Users
Enter the email address with which you have obtained your evaluation code. Leave the registration code field blank."

Which version of Opus?

If you right-click a file that isn't opening properly, does it show the correct item in bold as the default? What about if you hold shift and right-click the file? Finally, do you see the same item in bold if you right-click the file in Explorer?

Also, you can backup all your configuration using the Import & Export command. No need to lose it all, although of course if you reinstall Opus and then import all your settings then you'll probably be back where you were, but you can be selective about which settings you import.

Hey brother... I can certainly understand being aggravated when things don't work out... I've had some strange results with modifying file types settings myself... and so like Nudel says I make it a point to export my Dopus settings before making major changes. I keep a "known good" stable settings export, and then incrementally export 'in progress' settings as I learn more about how to use the internal command set and fart around with context menus and such. But I always go back to a stable exported settings file if things start to go wrong.

For my own part, and I can't yet qualify exactly what problems I sometimes see, I have noticed that after making certain blunders in my file types settings, that even after re-importing one of my "known good" settings files things don't always return to normal. I've also found that some of the file type settings that you can change in Dopus aren't necessarily stored in some internal Dopus config or dat file, but rather in the HKCR registry under many of the normal file system object keys, except in \opus sub keys. Also, some of the Events and Actions settings you still see in Dopus seem to be entirely pulled from the regular shell event keys in the registry... some are not. For instance, even if you've got the windows context menu items hidden in Dopus preferences, you will still see certain explorer shell related context items on some file system objects, such as Explore when you right click on folders. And sure enough if you delete the HKCR\Folder\shell\explore key, you will no longer see Explore as a right click option on folders. Be careful if you ever decide to delete stuff from the registry - Dopus can't protect you :slight_smile:.

Much of this doesn't seem to precisely help you with your problem though since it seems you say you aren't making changes like I am; that things just start to break in your case, but in the future definitely save the settings you've created with so much time and effort by using the export utility - it's real quick and easy. To try and fix your problem, you've got to find out what it is on your system that starts changing that's giving Dopus these problems. I say that because while I find some of the people offering support here can tend to be overly defensive of Dopus at times, it seems unlikely to me that your problem is some wild wacky Dopus bug. It can be tough, but since we know that many of Dopus file type settings are stored in registry sub keys under HKCR, maybe you can install some utility that monitors changes to the registry... there are some out there that will notify you when data in particular keys are altered, and maybe some that can tell you which app is doing it. And if you can't find out what is modifying the registry, between saving your Dopus settings and possibly comparing saved registry exports to new copies 'after' a change occurs, you might be able to figure out what's changed in case re-importing your Dopus prefs don't straighten things out.

Maybe Dopus could store a copy of the non-Dopus specific registry shell values it still utilizes - maybe have a checkbox in the Export and Import tabs to do this with a little note to users that importing saved non-Doups registry data could cause some apps that you may have installed AFTER saving the settings not to work and to use with caution or something... of course your problem may not even have THAT much to do with Dopus :frowning:.


Thanks for your answers, specially steje who wrote down a quite comprehensive dopus-regfiles interaction guide. :sunglasses:

Didn't know about the export-import option. From now on it will be my battle-horse :smiley:

The Dopus version was I think.. I was afraid of updating it because of losing my key.

Yes, when right-clicking the actions in bolded font were the right ones, and in that way it worked. The same for WinXplorer. The problem was when double-clicking, at this time the action started wasn't the bolded one (i.e. the default). I Didn't mess with strange setting involving double click and so on.

Right now when I double click an avi file (for example) BsPlayer starts playing it as it should, but if double-click another avi in the meantime or with BsPlayer is stopped the new avi won't start.

I didn't do much testing 'cos I have not enough time to fight with this, so now I work with both WinXplorer and Dopus.

Bet regards,


No problem on my part... plus Nudel's a pretty helpful dude. What you said about Bsplayer almost wants to tickle something in the back of mind... can't quite remember it though. I use Bsplayer also; when I get home I'll 'dblcheck' (ha) my settings and compare notes to you... I am not having the problem you mention. I'd be tempted to ask you about Bsplayer settings, but you said it still works as expected from Windows Exploder :frowning:.

Can you say any other oddities that you see other than the Bsplayer behaviour?

Anybody know of any utility that might exist to let people 'compare' exported dopus settings files? Or decrypt them out to cfg/ini type text files? Man that would be awfully handy... especially in cases like this. I'd try to write one but not sure if Greg and John would consider that reverse engineering :slight_smile:.

steje wrote:

Or decrypt them out to cfg/ini type text files? Man that would be awfully handy... especially in cases like this. I'd try to write one but not sure if Greg and John would consider that reverse engineering :slight_smile:.[/quote]

The exported prefs file (.dps) is actually a zip file. Just add the .dps extension to:

Preferences - ZIP Files - Settings - Extensions

Then you can access the dps file as you would a normal zip from within opus - you can then view the individual files within the "zip".

Excellent... thanks a bunch Tanis! And sure enough, the .DPF files are pretty much exported registry key data as far as structure. This makes things easy... Good lookin out!

If it's just BsPlayer that's not doing the right thing when files are double-clicked in Opus, there's a few things that are worth trying:

  1. Go to the Filetype editor, select the relevant type and click Open With at the bottom, then assign BsPlayer if it isn't already.

(Doing that is slightly different to assigning a double-click or Open item. I'm not sure exactly how different, though; the Open With feature added in Win2k (I think) always seemed a little odd and redundant to me, but sometimes using it can solve problems like this.)

  1. Make BsPlayer recreate its associations. (Usually if you turn them off and then back on again a program will recreate them. Not sure about BsPlayer as I haven't used it... Doing a reinstall of it might be worth a try.)

Also, if you shift-right-click a file and then select the bold entry, does that work? Or is it the same problem as when double-clicking?

Hmmm... the behaviour he mentioned below seems kind of strange to me if it were a file associations thing:

He could also try explicitly defining the 'dblclk' event for 'BSPlayer file' types as what the Open action is set to -> "C:\Program Files\Webteh\BSPlayer\bsplayer.exe "%L"" and see what happens...

duhhh... anyone know what's "%L"?

Hi guys!

Been out for a while so I couldn't post anything.

This time I troubled with winamp:

  1. Winamp Closed.When doubleclk in an m3u file winmap starts resuming last file it played, i.e., does not play the playlist I'm doubleclkng.

  2. Winamp Open. When doubleclk in an m3u file winamp starts playing normally.

  3. Winamp closed. When right click & select the default (bolded font) action, starts playing the list normally. The same for selecting the file and pressing 'enter'.

  4. Through winxplorer everything runs fine.

  5. Does not occur with mp3 files.

  6. Actions defined for m3u and mp3 are identical ("C:\Program Files\Winamp\winamp.exe" "%1")

So, I defined a doubleclik action under Dopus ("C:\Program Files\Winamp\winamp.exe" "%1") and now it works fine, but ... Why it behaved like that?
Only thing changed from one day to another was standing by the computer instead of turning it off. Restoring formerly working Dopus settings didn't help at all.... :confused:

Best regards


More on this!

Today just rightcliked a perl script and selected the bolded action "edit", which should load the file into an Hex Editor...

Fisrt try: Well, it just opened the file into notepad ... cool!

Second try: it openened a "%1" file (yeah that variable that recalls the file itself) and then the script in teh Hex Editor.... cool! 2 point for dopus!

Third try: it finally opened only the script into the Hex editor.

Man, this begins to smell strange ...

Best regards,


Something definitely smells strange brother... not sure what to say. Though when the results are not consistent, it usually is a caused by not necessarily a bug in an application but perhaps a bug AND some sort of environmental/config issue. I've got my gripes with Opus... for all of it's power it is sometimes lacking in straight forward ways to achieve certain things... but I can't imagine why you'd get something retarded like an actual file called %1 being directed to an application.

It seems that manually defining the dblclick action I suggested fixed that other problem - tho we're both stumped as to why it was necessary at all - can you do the same with this Edit action that is going haywire on you? Sucks you have to deal this way, but I can't think of a 'cause' for this happening to you.


Well, I did not tried to fix it this "hard way" cos from that day it didn't reproduce again, but as U see the problem is also random U´ll never now if it works due to the first fix or due to "at this very moment I decided to work properly" feeling from dopus ... :confused:

Apart from that is not feasible to fix all this issues with that solution.. imagine the same problem arising with every file type on this machine ... :astonished:

Also, I forgot to mention that two last issues appeared on version ... As long as I have the same problem on all version I do not pay attention to this point anymore ...

I guess the worst of all is that seems that I'm the only one stucking with this, maybe because Dopus is not widely known, maybe because I'm an unlucky guy or ... who knows ... I mean, I think I 'll have to suffer this forever or just leave dopus .... :frowning:

Best regards


hey there... yeah, this is a sucky problem brother and I can't blame you for leaving if you can't find a way to avoid it or at least figure out what's causing it...

I wonder if there is something in your configuration that could cause it... if you export your settings and a list of apps you use - I'll mess around with them and see if I can at least reproduce what you're seeing - I use bsplayer, but not Winamp (j River Media Center :slight_smile:)...

I wonder also if there's some registry monitoring utility you could install and configure to 'watch' the various relevant reg keys that Opus uses to handle click events... anybody know of a freeware reg monitor that would tell you which program touches specific reg keys?


Somehow it looks very much like a filetype issue I discovered between Opus 6 and DeliPlayer 2, which I thought was attributable to the latter but appeared to be a shortcoming of the former. Back then I didn't report it because Opus 6 was just being dropped in favour of Opus 8 -- so good they skipped a number? -- and I wasn't too keen on trying out the new version (no Unicode support, archive integration still limited to ZIP format...).

I'm pretty certain the problem still remains in Opus 8, but for the record and if GP Soft is willing to have a look at it, you can read all about it here. Hope it helps.

Hmmm... well that certainly sounds like a similar problem, as does what JohnWatkinson reported in this thread...

Although in 'that' case, it was something that I believe Opus was fudging because for some reason it seemed not to have imported 'all' the actions associated with .DOT template files for Word, at least 'initially'... but maybe somehow this is happening 'over time' with brothers problem...

Hey brother... would hate to see you leave Opus, are you willing to check some things for us? 'Next' time you have this problem, please check the HKCR in the registry, locate the key for the extension of the file you're having the problem with, read the keys (Default) value which will be a file type 'description' for which a key of the same name will also be located under HKCR. Underneath that key, there will be a shell subkey which should contain a few more subkeys that describe the shell actions registered for that filetype. Are ANY of them present in the Opus file type editors ACTION tab for the same filetype?

Nudel/Jon/GPS fairy, can anyone look into the issue referenced above with .DOT template file problem not 'opening' with the default DDEMessage command per Windows Exploders reg key indications... THAT one at least seems easily reproduceable, if you install MS Word you should see it. If you can explain why 'that' one happens it might shed light on what's happening to brother and Kaminari...

Hi again!

Well, and I thought I was lonely in this universe ... :smiley: Those problems reported seem to have the same origin as mine.

I think it really has to do on how Dopus registers/reads/stores fyletypes on the registry. After reading those posts, I suddendly remembered once curious thing it happened to me just some days all this began to crash down:

Everything was fine with dopus, and from one day to another, it appeared the problem with Winamp; as I was so happy with fully functional features of dopus I blamed Winamp for that issue (my error was not testing it under WinXplorer), so I messed with the player until everything worked fine. Basically the medicine was to command Winmap to re-register its filetypes again, and from that on, dopus began to work properly.

So the issue had to do with filetypes registration, as those post suggested.

Steje, as your rank indicates I "Just can't stay away" from dopus :sunglasses: Despite all this issues, when it works properly it really boosts up my production... It would really recommended it.

Sure, next time this crashes I'll try to take 5 minutes away to check what you told me.

And next time will be, as Murphy's law dictates, my next overloaded working day... :smiley:

Best regards


Hey Brother, well it's good to hear you're willign to work through the trials and tribulations :slight_smile:. I myself only have one very annoying problem with Opus hanging onto open folder handles requiring me to kill the dopus process periodically, but as you I absolutely LOVE the functionality I've gained by using it and so can deal with any other occasional issues that pop up. It's worth it... good luck in your file type action bug hunting quest. I'll keep a look out for updates from you to see if I can be any help...