Default folder won't stick

These are my settings:

Prefs/Double-click:

  • "Open new lister" is checked
  • "Support double-click [...]" is checked

Prefs/Layout/Opening Listers:

  • "Inherit [...] / Size" is checked
  • "Update Default Lister [...]" is checked (tried unchecked too)
  • "Double-click on desktop opens" is checked
    • "a new Lister" is selected

Prefs/Layout/Default Settings:
- Mode is "Single file display"
- "Status Bar" is checked
- "Position under Mouse cursoe" is checked

Prefs/Layout/Default Folders:
- First & second file display are both set to "My Computer"

Prefs/Layout/Lister Styles:
- "Single" has "My Computer" set as the folder to use.

I've opened a lister showing "My Computer", and selected Settings/Set As Default Lister.

I've saved a folder showing "My Computer" as my "single" Lister Layout.

Why is Dopus still opening "D:\Documents\Tabs" in every new lister I open by doubleclicking on the desktop? It drives me crazy. I want "My Computer" to be the default. The same happens if I select "New Lister" from the desktop context menu.

Do you have Use SmartFavorites checked on the Default Folders tab? That's the only thing I can think of.

Oh, man... That's it! But why?! That's just stupid.

I didn't even consider that it would change the startup folder. Why would anyone want that?

I don't use smart favorites, but I felt that the feature didn't do much harm. So I've just ignored every smart favorite setting there is. I guess that's why I didn't notice that "Smart Favorites" have an enable setting aswell.

But if it considers every time I open an lister as an access to that folder, it's no wonder that it's the most popular folder on my system. I open a new lister allmost every time I access something. It's not unusual for me to have 5-10 listers open at any given time.

Smart Favorites should have a big warning label. "Caution - this feature messes with your head". From now on, they're off on my system.

I have been having this trouble too, and the "Use SmartFavorites" checkbox is certainly not checked. Yet everytime I open a new lister, it opens to the last folder viewed before closing the last lister... any other suggestions?

btw: I'm running XP SP2, 8.2.02U.

If you're getting the last folder opened and don't want that then you most likely need to turn off Preferences / Layout / Opening Listers: (Inherit from the Default Lister) Initial folders.

Or turn off the checkbox below which updates the Default Lister settings when Listers are closed. Or turn that whole section off like I do. :slight_smile:

Thanks, that fixed it... :slight_smile:

It seems counter-intuitive though: As a user, I don't know of any abstract object referred to in the options as the 'defaul browser', which is getting updated by default when I close a lister... I just know that I told it to start at "c:", and it does not. :frowning:

For what it's worth, in my opinion the separate "Default Lister" should be scrapped (since it's confusing) and those inherit/update options should simply use/overwrite the preferences on the other pages when things change.

So there would be, for example, a checkbox that says "Update Default Folders" (when Listers close) and if it's checked and you close a lister then Opus changes what you see on the Default Folders page which in turn changes which folder is displayed by the next lister you open. The current system doesn't change the Default Folders page but instead saves the folder as part of the "Default Lister" settings which are hidden in the registry and only used if the "inherit" options are on.

That sounds perfect... much more intuitive and self-evident than the current system. :slight_smile: