DELETE command?

I've been banging my head on this ... finally, time to ask for help.

Before doing a batch image conversion, I want to delete the destination folder (not the destination lister) of the old conversions. Basically, in DOS speak, I want to do this:

del "c:\pics*.*"

I've tried:

DELETE FILE "c:\pics*."
DELETE FILE="c:\pics*.

I even tried
DELETE "c:\pics*.*"

What the heck am I doing wrong? I can't go with a pure DOS solution, since I'm executing Dopus commands in the same button script.

Any help appreciated!

Hi Shane,

I have this working :

Go C:\pics
Select All
Delete All Quiet

Be careful though .
The Quiet argument suppresses the Delete confirmation dialog.
You might want to leave the confirmation dialog in until you know your button is working.

:opusicon: porcupine

I'm wrong. It only works some of the time.
The delete starts before the files are selected and deletes the folder pics instead of the folder's contents only.
I tried sync:dopusrt /cmd in various combinations, but it didn't work either.

However, the first two lines seem to work all the time.

Go C:\pics
Select AllFiles

:opusicon: porcupine

Thanks ... that's one way of doing it ...

Anyone else? I COULD write a batch file to do it I guess - perhaps I can call it somehow with the CLI command...

Perhaps a dopus button command something like this?

dopusrt.exe /CMD delete file="C:\pics*.*" QUIET

Again as porcupine suggests, I wouldn't add the QUIET option until you know it's doing exactly what you want.

By the way porc, I seem to have lost your email address. I'd like to email you reference the RAW photo processing we were discussing a couple months ago. I have totally changed the way I do everything with RAW and I'm curious how you're doing it now, so it might be in both our best interests to compare notes again. If you get a chance drop me a line at would you? Thanks.

Yeah - I do this now in a button...[b]sync:dopusrt /cmd Delete "D:\my\pictures\temp\*.*" QUIET sync:dopusrt /cmd Image CONVERT=jpg QUALITY=100 TO "D:\my\pictures\temp\"[/b]

Weird .. the dopusrt isn't working at all here. The script stops on that command and doesn't continue (nor does it delete what I've instructed).

Does this have to be a DOS command to work? I have many script elements AFTER the delete that are Dopus commands, not DOS ...


You know what .. nevermind my incompetance ... the DELETE/RENAME issues I was having had to do with other parts of my script not working right - not these commands.

My apologies.

For those curious what I ended up with ...

Go "c:\new fg pics"
Rename TO "4ACX{dlgstring|Enter Episode 4ACX Number}_.bmp" NUMBER 1 BY 1 FROM ".bmp"
Delete FILE "c:\new fg pics\fulls*.
Delete FILE "c:\new fg pics\thumbs*.*"