Desktop double-click delay (due to Windows Defender)


I have DOpus 11.18 version. 64 bit.
After system start when i double click on desktop lister show up after 5 seconds.
After first lister show up is ok. Listers show up immediately.
But after a few minutes of inactivity it is the same again. I wait up to 7 seconds before lister show up.
Logging in DOpus is off.

When i run Opus via the Start Menu, or right-click the desktop and choose New Lister i have the same 5-7 sec delay.

Windows 10 64bit



sorry for my English :confused:

If Opus is running in the background it will be quick to launch - if Opus isn't actually running, it will be slower the first time a Lister opens.

The options in Preferences / Launching Opus / Startup control whether Opus runs on startup, and whether it stays running in the background when all Listers are closed.

This is my Startup settings:

That looks like Opus should be running in the background, but check that dopus.exe is in the Task Manager list in case something is blocking it from launching at startup. (Note: dopusRT.exe may also be running for the desktop double-click functionality, but dopus.exe is the one you want to look for.)

Another possible cause of delays which only happen if you haven't used Opus in a while is that one of your drives has spun down and gone to sleep, and then needs to be accessed when you open Opus, which blocks things until it has spun up again.

Task manager with no lister opened:

I dont have dopusRT.exe in task manager.

In power options i have "Turn off hard disk after" set to 0. No hard disk go to sleep.

DOpusRT is the 2nd Opus entry there. (Task Manager's Details tab shows the process names.)

Everything there looks correct for a quick launch.

Something Opus is accessing must be taking a while to load or cache the first time a window opens (or first time in a while that one opens). What it is could be a number of things, depending on your Opus configuration and PC configuration.

If you're familiar with a tool like Process Monitor, using that can quickly locate what is being accessed during the delay. If you aren't familiar with it then it might be a bit overwhelming, though.

Some of the suggestions here are worth trying if they seem relevant, as a quick list of possible things to try. (Ignore any that don't seem relevant, of course.)


Now after update to latest Dopus version after a few minutes break in using the computer.
When i double click on desktop i must wait about 10 seconds that the window appears.
This is very annoying :confused:

Windows 10 64 bit (latest)
system and Dopus is installed on a SSD.
32 gb ram
i7 4790K @ 4ghz
GTX 1080 Ti

My DOpus config:

Did you reboot after installing the update when prompted?

Of course. This is happend every time after restart.

If you revert to the default config, does it still happen? (Fastest way, if you already have a config backup, is to uninstall, then reinstall.)

After reinstall with all default config there is no delay. After double click on desktop window appear instant.
Just interesting what causes the problem in mine config? Any ideas?

You probably have something on a toolbar or starting folder/tab which is trying to load a path, or program (e.g. to load the icon from a .exe) which either isn't available (network path that's turned off) or is very slow to access (drive that's spun-down, or an .exe which anti-virus wants to keep scanning for some reason).

Ok. Thank You! I try to use all default dopus icons.
But in my toolbar with programs (steam, discord ect...) i want to have icons from those programs.
In starting window i have harddisk list (without any network stuff)

The cause of the lag is Windows Defender who check Directory Opus every time when i double click on desktop
Adding to the exclusion does not change anything. Now with Eset NOD AVirus is ok.

1 Like