Desktop Double Click Not Working with Winstep WorkShelf

Win Vista 32 SP2
DOpus Pro

Desktop double click does not work, nor does double clicking on the tray icon (that opens the context menu). This has occurred since at least but didn't have time to investigate previously. I've done the following:

  1. Tried changing "Double-click on the desktop" preferences from "Open a saved Lister layout" to "Open the Default Lister" and then "Bring the last active Lister..." [NO CHANGE]
  2. Tried changing "Double-click on the Taskbar icon" preferences from "Open a saved Lister layout" to "Open the Default Lister" and then "Bring the last active Lister..." [NO CHANGE]
  3. Reinstalled 10.2.0 Pro [NO CHANGE]
  4. Checked mouse settings [DOUBLE CLICK WORKS NORMALLY]
  5. Reinstalled PRO [NO CHANGE]

Any ideas?

Maybe you installed something, that intercepts your double clicks? Sounds odd to me, because
i assume, that those parts of code have been untouched for many versions.

Did you reboot after installing each new version?

@abr - not sure
@Leo - Yes, every time

Is dopusrt.exe in the Task Manager process list? If you turn on the Command Line column, it should be running with the /dblclk argument. (Windows Defender or other anti-virus tools might block it from running at startup, for example.)

You should also make sure that Opus (dopus.exe itself) is not running UAC-elevated as administrator, else the messages to open a new window will be blocked. (Using Opus's admin mode to elevate things is fine, but dopus.exe itself should never be run as admin if UAC is enabled.)

Tools which hook, modify or replace the desktop window may also break desktop double-click.


dopusrt.exe is in the process list with the /dblclick argument. I have UAC turned off, and the Administrator Mode button is disabled. I don't think I have anything that modifies the desktop window, but will investigate further.

The fact that you say the tray icon double-click isn't working either makes me think it's nothing to do with the normal problems that affect desktop double-click. What exactly are they set to open? Are you sure you're not trying to open a layout that's appearing off-screen or minimized or something like that?

I found the conflict. Winstep ( WorkShelf has a "Hide Desktop Icons" setting that apparently does more than hide desktop icons. Once disabled, both DOpus desktop and Tray Icon double click work appropriately.