GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Directory Opus Displaying Incorrect File Type

Attached is aa Adobe Acrobat pdf file extension being displayed as a Gimp 2.10.12 image file. All of my image file extensions, i.e. PNG, JPG, JPEG, etc. are being displayed as Gimp 2.10.12 image files.
I recently installed Gimp 2.10.12 but I left the image file specifications unchecked. How can I specify the Adobe Acrobat Reader for the PDF and correct image file file extensions.

Right-click the PDF, use Open With > Choose Default Program, select the "Always use this program..." checkbox at the bottom, then double-click Acrobat in the list.

That's usually enough to fix which program is opening when files are double-clicked.

Hi Leo,
Before posting this problem report, I had already set the "default app" for PDF files to "Adobe Acrabat Reader" as the default in "Settings\Default Apps\Set Defaults By App\Adobe Acrabat Reader DC" without success, i.e. "Adobe Acrabat Reader" file type appears as "GIMP 2.10.12" instead of PDF.
I use the file "Type" in DO to group specific file for searching, e.g. txt, pdf, xlxs, etc.
If all else fails, I could uninstall GIMP 2.10.12 first and then uninstall DO followed by reinstalling DO and then reinstalling GIMP.

Try the Open With menu. It sometimes overrides everything else.

If searching is the issue, you can search for *.pdf as the name instead of using the type drop-down, for a similar effect.

Leo, my problem is not solved. The problem is not with "opening the file," no problems whatsoever but with "displaying" the "correct file type" in DO's Lister. I even specified "Adobe Acrobat Reader" for File Type "pdf" to no avail.
I recently reinstalled Windows 10 Pro 64x to fix a problem which later turned out to be a faulty motherboard was replaced within the last month. I had just finished reinstalling the last app, i.e. GIMP 2.10.12 when this incorrect "File Type" appeared in DO.

The Open With menu will often fix that. Have you tried it? Using Open With to change the default app is not (always) the same as using the Default Apps settings window. They do slightly different things.

If it still doesn't work even after using, please do this in Opus:

  • Settings > File Types.
  • File > Diagnostic (at the top left of the File Types dialog).
  • Enter .pdf as the extension and push OK.
  • Attach the result here.

That may reveal an issue with how the PDF file type is set up. Sometimes the type isn't properly defined in the registry (only overrides on it, not the type itself), which can make Opus and Explorer do different things, as it's an invalid configuration. A lot of PDF software seems to fight over and mess up the PDF file type, so strange things can happen to it at times and the fix may require changes in the registry.

Hi Leo,
Attached is a PNG file which shows the file attributes in DO for Adobe File types as Gimp 2.10.12 type.

Please send the diagnostic I talked about in my previous reply. That will let us see where things are messed up in the registry and tell you how to fix them.

Here's the requested file.

That's the same image you posted before. Please see Leo's request above for the diagnostic file for the filetype.

This is the output file.
Opus_FTD_File_pdf.zip (43.4 KB)

Thanks for the diagnostic.

This doesn't look like it's anything Opus did, or even specific to Opus.

Do you see the same Type reported for PDF files in File Explorer?

The .pdf type has been taken over by GIMP on your system. From the diagnostic:

64 HKCR\.pdf: "" is REG_SZ: "GIMP2.pdf"

Editing that value in the registry so it is AcroExch.Document.DC and rebooting may get you what you want:

  • Run RegExit.exe
  • Navigate to HKEY_CLASSES_ROOT / .pdf in the tree on the left
  • Double-click (Default) on the right, and change it from GIMP2.pdf to AcroExch.Document.DC

Failing that, or as an alternative, repairing or reinstalling Acrobat may also make it take over the file type again. (But GIMP may in turn take it over again the next time it is updated, unless it is configured to stop doing that.)

Failing both of those things, you should talk to the authors of GIMP or look for help on their forum about how to avoid GIMP taking over the PDF file type, as it is GIMP that has done that, not Opus or Acrobat. Opus is simply displaying the state of what is in the registry, and the File Type Editor in Opus cannot change the actual file class extensions are mapped to, which is the issue here.

Thanks Leo.
The easiest thing for me to do is to uninstall GIMP and then uninstall Directory Opus using "Revo Uninstaller Pro." I will then reinstall "Directory Opus" and hopefully, this will solve my problem. I hardly use GIMP anyway.

It's nothing to do with Opus so there is no reason to uninstall/reinstall Opus.

Please don't use things like Revo on Opus either. They tend to cause problems rather than solve them.

I think if you reinstall Acrobat it will probably fix things by taking over the PDF type again. I would try that before doing anything with GIMP, and definitely before doing anything with Opus.

Opus is just reporting the file type information in your registry. The information was not put there by Opus, so it's the least relevant component of the three things involved.

Leo, I uninstalled and then reinstalled Adobe Acrobat Reader; pdf files still displayed a GIMP 2.10.12 file type.
I then uninstalled GIMP and Directory Opus now displays the correct file type for PDF files, i.e. "Adobe Acrobat Document."
When I originally installed GIMP, I did not specify any File Types which GIMP would associate with, i.e. png, jpeg, jpg, etc. I will reinstall GIMP later to recognize these file types.

(Apologies, I misread your reply.)