GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Directory Opus Slow Start (Solved)


#1

Hi there, I just wanted to drop by in case someone else had the same issue as I did and wasn’t able to find an answer to the problem in the forums. I’ve already solved it myself, but I figure it always helps to have it documented.

Basically, the issue was that every single time I wanted to open Directory Opus, literally from the moment I installed it, it’d take 10-15 seconds to start. Recently, it started taking even longer - up to a minute - so I started to troubleshoot.

After hours of searching the internet to no avail and a few full resets/reinstalls of Opus, I noticed that attempting to open some of my libraries would literally freeze Directory Opus to the point I’d have to force close it. There was also an errant folder under my Music library that I was unable to remove and seemingly led to nowhere. I went to my regular file explorer and checked my libraries. Nothing showed up.

So next, I decided to reset my libraries. I used both the Directory Opus menu option as well as the default Windows option in an attempt to “reset” my libraries - no dice. Still had the issue.

So finally, after connecting the dots, I was able to figure out that I had somehow stupidly managed to add two local folders as shares from a network.Since I’d removed the shares from my PC, Opus was choking on it, and for some reason removing the shares made them invisible and untouchable in my stock file explorer.

What finally solved it was going to the “libraries” folder in the stock file explorer, going to “Library Tools” and removing the shares from there. For some reason resetting them didn’t work.

Now Directory Opus opens instantly, which is great.

Just figured I’d put my solution here in the off chance someone else has something similar.