Disable autoplay audio files (mp3 in this case, but any and all)

How can I disable autoplaying of mp3 files?

I don't mind (in fact I prefer) it show in the medial player in the viewer pane, but I don't want it to just start playing.

As an alternative, is it possible to persist the state of the mute/volume settings? I thought this might be a workaround but the player resets the volume to max and with mute off each time you click on a file.

All I can find is posts from 2012 and 2009, and none of those methods work, or they refer to pugins or settings that are no longer present.

Worth noting that I have tried disabling autoplay in the movies plugin (as suggested by posts from years ago) and not only does this not stop audio from autoplaying, but doesn't even stop movies from playing either.

This method should work, assuming the Windows Media Player preview handler is working. Check that you can view the files in File Explorer's viewer pane to test that.

For anyone who might come across this in the future, there are 2 crucial points here.

  1. The Windows Media Player settings is inside the Active-X+Preview... plugin, something which not all previous posts made clear

  2. You have to add .mp3 (and whatever else you want) as a file extension to the player options in the settings dialog (something which nobody pointed out, as far as I could tell).

Anyway, This will do for now. It's a shame because the default player is nicer, but autoplay is a deal breaker.

Needing to do 2 is unusual but may happen if another player breaks the registry entries for the file type.

1 Like