Display Multiple Folders as One

Hi, I have tried using Libraries but I keep getting an error saying "This folder can't be included due to a group policy setting". It doesn't make sense, so I started investigating Collections and Stored Queries.

Collections don't really make sense because I'd have to do manual work combining the contents from multiple folders into one.

Then today, I discovered Stored Queries. This seems like the answer. However, I don't want to display the contents of all subfolders, I only want to display the immediate folder contents, excluding the content of subfolders.

I tried using this thread for reference, but couldn't get anything to work: How do I search for files and exclude subfolders in Windows 7? - Super User

I tried this query:
to generalize to any current directory: * -folder:".\*"

That didn't work.

I'm at a loss. Anyone have any suggestions? :slight_smile:

You could use a simple Find command for this, like

Find NAME=*.* IN D:\test D:\test2 RECURSE=no

Bonus: Will very likely be faster than Windows Search.

Thank you very much!

I had to specify "ADVANCED" because some folders were not being found in the find results. I have no idea why it was needed, but it solved the problem I was having.

Also, I don't know if specifying "CLEAR" is required but it doesn't seem to hurt.

Last but not least, I specified a collection name with COLLNAME so that the results go into their own collections.

I was able to create several buttons that did exactly what I needed!

Some examples:

Combine all of my Steam Games into a single folder:
Find *.* IN "C:\Program Files (x86)\Steam\steamapps\common" "D:\Steam\steamapps\common" "D:\SteamLibrary\steamapps\common" "E:\SteamLibrary\steamapps\common" "F:\SteamLibrary\steamapps\common" "H:\Steam\SteamApps\common" "J:\Program Files (x86)\Steam\steamapps\common" "Q:\SteamLibrary\steamapps\common" "R:\SteamLibrary\steamapps\common" "S:\SteamLibrary\steamapps\common" "T:\SteamLibrary\steamapps\common" "X:\SteamLibrary\steamapps\common" RECURSE=no COLLNAME="Steam Games" CLEAR ADVANCED


Combine all of my ShadowPlay folders into a single one:

Find *.* IN "F:\_ShadowPlay\Save" "H:\_ShadowPlay\Save" "Q:\_ShadowPlay\Save" "S:\_ShadowPlay\Save" "T:\_ShadowPlay\Save" "W:\_ShadowPlay\Save" "X:\_ShadowPlay\Save" RECURSE=no COLLNAME="Shadowplay Save" CLEAR ADVANCED

Very nice result!

When do you see that error? Does it also happen in File Explorer?

If you remove ADVANCED and change the *.* wildcard to just *, then it should work.

(I'm not sure why adding ADVANCED would have had an effect there, but I think the real problem was using *.* as the wildcard. That would only match files or folders that contain a dot, and most folders do not have a dot in their names.)

It's not incorrect, at least. I think it may be what happens by default, but it doesn't hurt to be explicit in case that isn't always true.

(CLEAR on its own clears the old results collection before adding the results of the new find. CLEAR=no would prevent that, and accumulate the new results on top of the old ones.)

Indeed. Like in RECURSE=no.

Some of the options may default to the current state of the checkboxes in the Find panel (although I am not sure when or if that is still true; it's something we've moved away from, since predictable commands are better).

1 Like

Yea, I just tested this. It happens in File Explorer too. It's possible I have something misconfigured in Windows. Hard to say. I tried poking around in the Group Policy Editor and doing some google searches but gave up pretty quickly. Surprised this issue isn't more widespread.

Oh god, then you would HATE blender. lol

In Blender, when you're setting up keybinds, every option has 3 possible states. True/False/Undetermined... it's the undetermined state that causes the option to be become whatever the user chose last. So, whenever I'm setting up keybinds in Blender, I find myself sometimes setting up 2 separate binds. One for FORCING the keybind to default every setting so that I can get a persistent result, and then another keybind that repeats the command, but uses undetermined so that all of the previous settings can be repeated.

If any blender users are looming about, they might say, "why not just use the default repeat key to repeat the last function?" Well, problem with that is, if you accidentally do some action after customizing your previous bind, you lose the ability to "repeat last"... so you almost need a feature called "repeat last before last", but then some Blender users would be philosophical about this and say, "that's too niche of a feature so it's not going to be implemented in standard blender". So then it forces me to create extra ■■■■ing binds to deal with this problem.

It's powerful, yet it causes me a great deal of stress/anxiety because with every new version of Blender I have to set up all of my binds all over again. I almost don't even want to customize Blender and live the default life, which is probably why I hardly do anything with that program now.

I want to meme on Blender so hard by saying, "one does not simply use blender with default settings" but there are idiots out there who pride themselves in this. They actively pursue downloading blender, using default settings, REFUSING to modify anything out of box, and then produce youtube videos while bragging about it. It's like some weird fetish. I can understand if they're doing it to make their yotube videos easier to follow for others, but no, these guys actually get off on it.

I had to a friend who took months to convince him to use a few Blender add-ons I was developing because in his mind, the functionality already existed, therefore he didn't see a point in using them. After months of convincing, he finally gave in and agreed with me that I was right all along. Eventually we stopped being friends. It just wasn't meant to be.

Coming back to this, adding ADVANCED to the command was switching it into a mode where it ignored the specified wildcard completely (since the Find command was using an advanced filter, which the wildcard doesn't affect). That explains why it seemed to fix things when the wildcard was also wrong.

ADVANCED shouldn't ever be used in this context, but we'll make a change so that using it is harmless, since it's confusing that it changes what happens.

1 Like

Haha, that's really interesting. I didn't realize that this thread would contribute to a positive change to the program.

Thanks for your support! :slight_smile:

1 Like

I noticed that collection sizes are not recalculated when performing a Find, even when I have "Get Folder Sizes" set to Automatic.

Can you confirm for me? I am on Dopus 12.18.4 Beta x64

(This should really be a separate thread.)

It works fine here, in Opus 12.23. Make sure you have saved the change (you should see the format under Preferences / Folders / Folder Formats, in the Path Formats section at the top), and not that that setting only has an effect when you change folders, not after the fact. (If you want to calculate folder sizes after changing to the folder, use Edit > Calculate Folder Sizes.)