Displaying unicode filenames correctly

I'm running WinXP Pro Sp-3 and Dopus 9.1.1. Windows Explorer displays unicode filenames correctly (Korean) while Dopus does not. Bizarrely, the unicode is "revealed" when I use the rename function. See screenshot below.

Any thoughts? I can't find anything in the manual, help file, or Preferences that controls this behaviour.

Thank you,


Can you put the filename into a unicode text file, zip that up and attach it to a reply?

Unicode filenames work fine for me in general but maybe there's something peculiar about Korean, the fonts involved, and the way different controls draw text or handle font linking.

Which font are you using for the file display?

Hi Leo,

Thank you for your reply. I've attached a unicode text file containing one of the filenames - it displays correctly in Notepad on my machine. The display font that I am using is Segoe UI 10 point for file display.

I just had a thought and tried displaying the contents of the folder as Images and the Korean is rendered correctly.

You're on to something, though, because the next thing that I tried was to change the font to Tahoma, which solved the problem... I'd like to be able to use Segoe UI, but this is a simple fix!


Unicode filename.txt (34 Bytes)

I haven't tried XP yet but it works okay on my Vista machine with Segeo UI 10pt.

I think it's going to be something obscure about font linking, which is a bit of a black art. It's interesting that it works in the icon modes but not in details mode. There must be a slight difference in how the labels are displayed as well as a difference in how XP's font stuff is choosing to find fonts for the Korean based on Segeo UI and Tahoma. (And yet another difference with Vista, unless I've got a different version of Segeo UI... So many variables. :slight_smile:)

I'll copy the Segeo fonts over to my XP machine later and see if I can reproduce it. If I can I'll submit a report to GPSoftware to ask if they can see anything obviously different about the text display in the different modes.

Cheers, Leo! FWIW, I the Segoe UI font installed on my XP machine came from my Vista (Home Premium) machine. DOpus 9 displays the filenames correctly on that machine (hadn't thought to check it before).

No worries about this - I've changed back to the default fonts (and font sizes) for XP and all is well.

This is an old thread, but I have the same problem in 2023 (although not with Korean characters).

Some Unicode characters (:heavy_check_mark::warning: :radioactive:) are not displayed correctly in Dopus in the file name. Instead, a spiral symbol is displayed:

Windows Explorer displays the same Unicode characters correctly:

What could be causing this?

Same as the original issue/thread. The font you have chosen doesn't support those characters.

The default font should be the same one File Explorer uses, and will work.

OK thanks -- but the funny thing is that Dopus (with practically the same settings and especially with the same font) displays the Unicode symbols correctly on my laptop. Both computers are running Windows 10.



Windows does font linking so it could also be that another font isn't installed, although it seems a bit odd, unless you have different versions of the main font on the two machines.

At the end of the day, this isn't something Opus is doing. Opus tells Windows to output the characters in the font you have chosen, and the rest is down to Windows and the font (or fonts, if font-linking comes into play).

Try with Segeo UI which (AFAIK) is still what File Explorer uses. If it works in that, then you know the issue was with the font you were using.

1 Like

OK thanks will do.

So I've now tried a dozen different fonts, including Segoe UI, and in none of them the symbols are displayed :thinking:

Maybe the symbol font on that machine is messed up in some way. It looks like it's displaying a different symbol to the one you expect.

I don't really know though. It's down to the fonts and OS rather than anything we are doing.

Dopus displays the symbols :heavy_check_mark::warning: :radioactive: elsewhere as well. Just not in file lists :man_shrugging:t3:

But they work fine on your other laptop. The issue is outside of Opus.

Yeah, but I wonder what this could be. IMHO this is not a case of some special symbol font, but simply Unicode characters of the very font that is used :tipping_hand_man:t3:

Are the two machines the same version of Windows? It doesn't look like it but that could be the theme modifications.

The machines are both Windows 10. The PC only has a different theme than the laptop. However, I have now deleted the Dopus configuration, and lo and behold, the Unicode icons are displayed correctly in Dopus. What now...?

When I restore the configuration, the issue comes back, even when I deselect all options:

Only you can know what you've changed in your config, but I would suspect it comes down to the font settings.