DO isn't working with Desktop Icons

Hi There!
I have a small, propably stupid problem.
My Win10-PC with the newst DO works fine, EXCEPT: The icons on the Desktop are still opened with the Windows Explorer, not Directory Opus.
I activated "Replace Explorer for all folders" - and it just isn't accepting that omn the Desktop. Anybody got an idea what I did wrong? (P.S. Same machine, bevore the current update, it worked perfectly fine)

Thanks for any tips!
&Greetings from Munich

  • Is Explorer Replacement working anywhere else?

  • Try turning it off ("Don't replace Explorer") then click Apply. Wait 10 seconds. Then select the desired setting again and Apply/OK. That may repair the registry settings if they have been changed by something else.

  • Also make sure you aren't running the whole Opus process elevated (as admin), since that would block the ability for the desktop to ask Opus to open folders.

    (More detail here. Elevating individual windows using Opus's Admin Mode is fine. Launching dopus.exe elevated will break things.)

  • Another thing to check is that no Compatibility Mode settings are turned on for Opus. If it thinks it is running on a different version of Windows it may try to replace Explorer in the wrong way.

  • Another possibility is that antivirus or another tool are blocking or intercepting things before Opus can see them, althouigh that is not something we've run into before with Explorer replacement.

Hi Leo!
That turning it on/off worked - changed the settings two times, (Completly off & Replace for all file system folders)
restarted DOpus each time, and now it is working - thank you very much for the tip!

Greetings, Bela

1 Like