DO not opening when I insert a USB

GO easy with me here, please; I am not the sharpest knife in the drawer where tech stuff is concerned!

I have had DO 10 'light' for a couple of years now and previously used it on W7 but have just recently upgraded to W10 64bit.
Even when I used it before, the DO directory never opened up when I put in a USB-based drive (i.e. back-up external drive, memory-stick or any other USB).
It always gave me the OPTION to do this and I would routinely click 'use DO' as opposed to other file manager options, but then it just sat and did naff all.
I re-set the options from control Panel and tried again, but with the same result, so I soon gave up on it and simply resorted to plugging in the drive then double clicking DO from the taskbar.

Now, I WAS hoping that when W10 came along it would sort itself, but alas, 'tis still the same.
I get the option to open USB drives with DO, click it and then nothing happens.

What's going on?
What have I done wrong?

MT :wink:

Oops! Just seen posts on my previous thread relating to this (but for some reason never received notification of those replies!)

So, it seems as if DO Light does not support the most basic of requests, i.e. won't open automatically if I insert a USB-drive, yes? :frowning:

MT :wink: