GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO slow performance in Windows 10


#2

Have you tried using a default config, in case the problem is caused by something in your configuration?

Backup the config first (Settings > Backup & Restore), then uninstall Opus, reboot, and then reinstall Opus. You'll then be using the default config. Does the problem still happen?


#3

I'm using the portable version with a USB dongle.


#4

The portable version still has your configuration in it.


#5

I'm aware of that. I'm deleting config folders and restarting DO to see hat might be causing the issue.


#6

Here is what I just did...

-Restarted my computer. I use DeeoFreeze, so changed to system are reverted on startup.
-Installed DO to system and didn't import old settings.
-Exported a portable copy and didn't import old settings.
-Restarted my PC, so all changes to the system where gone.
-Launched NEW DO portable copy and tested it. I could see the lag and stutter when resizing the main frame immediately. The stutter and lag is not as bad as with my old portable copy, but it's THERE.

Other apps like Firefox, WinRAR or Windows built-in explorer have no such issue, butter-smooth reszing, instant, the corner of the app is right under the mouse no matter how fast I move/resize it.
Again, I only noticed this lag issue in DO in Windows 10.

My laptop is brand new with high specs.

Please help me, I can't get any work done and I can't install Windows 7 on my new machine.


#7

What else do you have on your laptop? Maybe try disabling any antivirus or antispyware software you have and see if it makes a difference.

We've been using Windows 10 for several years so I suspect we would have noticed if there was a general incompatibility.


#8

I don't use any antivirus, anti spyware or even firewall. Even Windows built-in firewall is turned off for all profiles. Except for deepfreeze, all my apps are portable, any app that writes to the registry or appData is deleted forever. Speaking of which, I noticed DO portable still creates a folder in AppData called GP Software or something like that :confused:

Can anyone record a video resizing DO frame via corner on different speeds and upload it? Would like to see if it's as smooth as WinRAR or Firefox.


#9

The speed of window resizing seems like a strange metric to judge performance by. Do you use your computer for anything else or do you just sit there resizing windows all day? :wink:


#10

Are you sure you're using the portable copy? If the installed copy is running in the background, launching the portable copy will just send a message to the installed copy to open a window.

Testing Opus when it was a clean install is a better test than doing it after the reboot which restores all the other things to the system.

My suspicion would be GPU drivers. Are they installed on the machines that are having problems? Try reinstalling them, as Windows 10 has a habit of replacing proper GPU drivers with generic or half-broken versions when it updates, which can slow things down considerably.

Other than that, I'd test again with a clean install and double-check it's really using the default config (as discussed earlier in this post), and look into third party utilities which may affect things.


#11

Hi folks!

I would like to add my thoughts. I use DOpus at home from an SSD in my PC. At work i use the USB export. And i use DO a LOT! 8 hours daily at least. From my experience:

USB version:
Some things really slow down DOpus, like opening the toolbar config menu, resizing the window (i have lotsa custom made toolbars), sometimes scrolling with a lot of files selected (by a lot i mean 300+). For example, when i need to configure a toolbar, i right-click, click on customize, now sometimes i have to wait a few seconds, the toolbarconfig opens, then edit a button, then OK (for the button changes), OK (to close the toolbar config) and lotsa times if i dont wait between the OKs, the changes i made to the button do not show up, nor save. Or when i resize the whole window it stutters like in the video @Pear has posted.
Thougths: for the window stutter, i accept it because i think the system tries to redraw a lot of toolbar elements at once. As i said i have everything customized to the teeth. For the slow config opening and saving, i think Windows itself is either scanning the USB drive, thus the saving of the config sometimes works, sometimes doesnt. I think its more the porblem of the OS than DOpus.
On the 8GB Datatraveler USB: DOpus, 500 icons, 20 mp3 files, 378MB of apps, like ffmpeg, foobar, 7zip, nothing too resourcehoggy. Tried on WIN10pro 64 (home and workplace) and WIN7enterprise 32 (workplace)

PC version:
The config thing and others are fast as they should be. The window resizing is still stuttery, i dont know why, i have a GTX650TI nvidia card, i think its Win10 again, maybe something in the method it redraws all the toolbar elements.
On the PC its WIN10pro 64, default antivirus, everything default, fully updated. Default drivers offered by windows, i only play games and manage files, watching movies and listening to music.

So i also experience the things @Pear does, but i could live with them, they do not conflict with my working experience, but looks like its not just me. At home i have an AMD cpu, Gigabyte motherb, GTX650TI (something like a 4-year-old computer) and i maximise power usage, no battery saving stuff, no USB sleep and any other thing. So i just wanted to tell you that @Pear is not the only one with these issues.


#12

USB sticks can be quite slow. Using the option to export a portable version that can be copied to a HDD and just needs the USB stick to be plugged in can avoid that issue.


#13

Spent hours the last couple of days trying to figure out what is going on. I'm now pretty sure DO has a bug under Windows 10.

Here is what I did.

DIDN'T use USB version this time. DIDN'T use old DO copy.

  1. Formatted system drive via PE (AOMEI Partition Assistant).
  2. Installed a fresh copy of Windows 10.
  3. Backed up: Booted into PE and backed up C drive.
  4. Updated Windows, restarted few times, disabled Windows auto update via gpedit.
  5. Installed all drivers.
  6. Installed DO and ran it. Problem is there.
  7. Restored backup image in step 3.
  8. Step 4, no step 5, step 6. Installed DO and ran it. Problem is there.
  9. Step 7, 4, 5.
  10. Installed runtimes packs. Installed DO and ran it. Problem is there.
  11. Step 1.
  12. Installed Windows 8.1 on same machine.
  13. Step 4, 5.
  14. Installed DO, no problems whatsoever on both installed and USB version (USB is used as dongle only).

Tried Windows 10 64-bit, version 1709, 1803 and 1809.

So I grabbed one of my 5 year old laptop that runs Windows 7, formatted it and installed a fresh copy of Windows 7, installed DO, guess what? Not a problem.

DO is slow and stutters badly for me under Windows 10 in many ways, not just resizing frame. It's an issue when showing/hiding second pane or browsing/opening folders despite how many items they contain.

My laptop is brand new with high specs, 2 brand new Samsung Pro 970 SSD drives. My USB version of DO uses USB dongle and runs directly from D drive. Running it from second SSD drive didn't help. Stock SSD (Toshiba) didn't help.

I don't know what else to do. This is the first time I had to use XYplorer in years because of how unusable DO is under Windows 10 for me.

Can I pay to have you look into this problem?


#14

If that was the case we'd all be seeing the same thing, not just one person.

All of the 12.10 four-part videos were recorded on Windows 10 and you can see there are no slow rendering issues in any of those.

It's impossible for us to investigate as we have no way to reproduce it so far, and have literally no other reports of the same issue.


#15

I was testing stuff.
I reinstalled DOpus completely. With all default settings the window-size dragging still laggs, stutters. And i figured out that Microsoft Excel is doing the same stuff. But if i have a web browser open with 20 tabs and a youtube video playing, the window-resize-dragging is smooth. I started reading and found that for some people the mouse-polling-interval is causing problems. I have a Razer Naga mouse, with its driver installed and it supports 125Hz, 500Hz and 1000Hz speeds. I was fiddling with these, and even Windows10 CFG (Control Flow Guard) in the exploit protection settings (there are some people who had problems and this solved it for them). None of these help. I have the latest Nvidia drivers for my graphics card. Plugged my mouse in all kinds of USB 1, 2, 3 ports.

So there are a few programs, namely Excel and DOpus, which lag when you try to resize their window. So there is definitely something which i also experience, like @Pear, I just didnt feel like reporting it because i rarely resize the window frame. I can live with this, but if we call this a bug, or problem, it exists. DOpus window dragging is perfectly fine, only the resizing drag is laggy as hell.

My spec:
Win10 Pro always updated, CPU: AMD FX-8150, 8GB DDR3, Nvidia Geforce GTX650 Ti 1GB, no antivirus software, im using windows defender, the default in Win10.
Win10 on a Samsung 120GB SSD solely, DOpus on another 60GB SSD solely.


#16

Excel has incredible lag when resizing and moving the window with mice which have fast polling rates. Opus has nothing like that, at least in my experience. (My mouse polls at 1000Hz, and I see the problem in Excel every time I use it. Opus is nothing like that and does not have the same issue Excel has. If I move the mouse/window around in fast circles for a few seconds and then let go of the mouse button, Excel's window continues to move, catching up, for a second or more.)

I see nothing like the video above. Some programs resize more smoothly than others, but the video above shows it looking like a slideshow, which is definitely not normal.


#17

Yeah so in Excel, you know what im talking about, it only behaves if i set my polling to 125Hz. But for my life i swear i tried everything in my power, editing registry, different drivers (like gpu from Asus and Nvidia), different settings in Win10, turning off services, dumbing down Win10 like beyond proper functioning, and i can not figure out whats causing it. Yep different apps resize with different speeds, but DOpus is really slow on my side, just like the screenshot. I will keep trying, reading forums, hunting on the internet, i just wanted @Pear to know he is not alone. I will surely get back here if i find something!


#18

I would make a backup from actual sys (e.g. with Reflect), install a fresh version of Win 10 from CD/USB (not only resetting Win 10), then install DO using default and clean config and install no drivers. If DO works, your actual sys simply is not ok and you should rebuild it (maybe problem occurs again, but then you may find the reason on step-by-step installation)!


#19

Pear did that. But i did not find any other app that does the slow-resize-drag thing besides MS Office apps, so i dont think a fresh install does any good. Thx for the comment though!


#20

I can confirm that I am having significant slow down issues with the new release of DO under Windows 10. Directory Opus is consistently consuming roughly 25-35% of the CPU and Task Manager does not permit me to shut it down. If this doesn't change shortly I will need to uninstall. Apart from this, I have had a great experience with DO and have wished that it was the default file explorer in Windows.


#21

While resizing, or all the time, or at other times?

If it's not while resizing, then it's probably different to what this thread is about.

Excessive CPU usage in Opus is usually caused by 3rd party components that hook into the process, such as shell extensions. See here to troubleshoot that kind of issue: