DO v10. F5 on LAN drive throws it to Desktop

DO v10. Same issue as with initial DO v10 release: :cry:
When I am browsing LAN drive (directly go to server) and press F5, instead of refreshing folder DO cursor on folder tree jumps to the top – in my case Desktop - and file side shows recycle Bin. On all drives (local, mapped LAN) it works as it is suppose to.
This was the issue I reported when you released V10.

Work docx with screen prints before F5 and after has been attached.

While I could reproduce a similar issue, as mentioned in your earlier thread, I can't reproduce it anymore. (Jon fixed that in response to the bug report I filed, and that fix is definitely in

I've tried again, using XP and making the setup as similar to your screenshot as possible, but I couldn't get it to go wrong after trying for some time.

If you haven't already, contact GPSoftware Support (link in my sig) to send an official bug report.

Is anyone else reading the forum seeing anything similar? If so, it'd be useful to know your configurations.

Leo: Every F5/Refresh on network shares I've tried (XP SP3 and 7) all work. DO on 7, version on XP

Adamov: Is there another share you can test the F5 with? I'm still trying to figure out why your drill-down path (in the tree) is showing "ShareName on ServerName". Usually that only shows up under "My Network Places" and Mounted shares... not while drilling down to the share like the Tree shows (even though you used a direct link).