GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO12 - Crashed triggered by icon set

I can't run the new DOpus 12 beta. Installation and licence manager are working but when I try to start DOpus I get the following error message:


dopus.exe and dopusrt.exe are running in taskmanager. This happens with Windows 10 and Windows 7 on the same machine. I also tried a virgin installation without my old configuration.
Crashdumps are attached [now removed as no longer needed].

It looks like one of the icon sets under either of these two folders is causing the problem:

C:\Users<username>\AppData\Roaming\GPSoftware\Directory Opus\Icons

C:\ProgramData\GPSoftware\Directory Opus\Icons

Try moving everything out of those folders, then launch Opus to confirm it works. If it does, put the icon sets back one by one to find out which one is causing the problem.

If you find the icon set causing the problem, please sent it to us so we can work out why it's happening.

Thanks for the quick help. Can't wait to test all the new features. :smiley:
It was an iconset I created myself which worked fine with DOpus 11. It turned out it contained an icon which dimensions didn't match the size defined in the xml file (32x27 instead of 32x32 and 22x19 instead of 22x22). After repairing this DOpus 12 is starting fine now.

Please send us a copy of the iconset so we can fix the crash.

I've sent it to your mail address.

Fixed in 12.0.2