GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DO12 - Viewer Toolbar not there

After upgrading a v11 installation to v12, I cannot get the image viewer toolbar to show up in the viewer pane or in the standalone viewer, regardless if it's fullscreen or windowed. As fas as I understood, it should be visible in the standalone viewer and also in fullscreen. The "marked pictures" area is there, which is another indicator for me, that the toolbar should be there as well?

Don't know for sure though, this is new terrain.. o)

What's set here?


When full-screen, the toolbar won't be visible until you click the top of the screen. But when not full-screen, it should be visible.

Note that the toolbar only appears in the standalone viewer, not the preview pane.

The toolbar setting is the same here, still no toolbar visible in standalone/windowed mode or fullscreen after clicking the top of the screen.
Any more things to check? o)

Is there an Image Viewer.* file under /dopusdata/Buttons?

Yes, the toolbar itself is there and I can toggle it visible in a regular lister while in customize mode e.g., I just can't make it show up where it is meant to show up.

Does selecting any of the other toolbars work?

It may just be toggled off, try pressing Ctrl-N in the viewer.

Mhh, some progress! o)
I can set the toolbar to be a different one than "Image Viewer" and then I can get single buttons of any other toolbar to show up at least by hovering the mouse in the upper section of the window. On window resize, the toolbar will be gone again until I restart painting buttons with the mouse cursor. I can get it to show completely by pressing "" and if I open an image by doubleclick (fullscreen viewer), I can see the toolbar flicker once very shortly if I'm lucky and then its away again. Getting parts of it back by hovering the mouse also works in fullscreen.

Unfortunately, all this does not work with the "Image Viewer" toolbar, it's prefers to hide completly.


EDIT: Jon you nailed it. CTRL-N only works for the "Image Viewer" toolbar it seems. I can indeed make it show up with that key-combo.
So now this is different. In case the image toolbar is off, but set to be not the "Image Viewer" toolbar, all the magic described above can happen.

I had a look on how to enable the image viewer toolbar by myself (in case there is an option somewhere), I couldn't find something, but now I learned about CTRL-N! Thanks! o)

Btw: I needed to check "Always use toolbars keys.." in the customize toolbar section to get at least some key-combos to work.
It seems these changed quite a bit from earlier days and are not visible anymore in the viewers context menu.


The command Ctrl-N runs on the default toolbar is Show VIEWERCMD=toolbar. We should probably make it so the viewer toolbar is automatically turned back on (if it's off) if a different toolbar is selected. We might add it to the window menu as well (like the Lister has Preferences / Customize commands).

Fixed in 12.0.2:

[ul][li]If the viewer toolbar is turned off it will now be automatically turned back on if the user selects a new toolbar in Preferences. Also the window menu of the viewer now has a command in it to toggle the menu bar on and off.[/li][/ul]

@tbone: If you still get those graphical problems with the toolbar, please let us know, and any hints for how to trigger them.

Jup! Will do, thanks! o)

I need to come back here, because I have new difficulties with the viewer toolbar. There is again no viewer toolbar visible (another DO12 setup this time) and no obvious way to make it show up. When in fullscreen mode I cannot reliably double click at the top or press the ctrl-n hotkey to make it pop up. The hotkey only works reliably if viewer is not fullscreened. Clicking at the top only works if ctrl-n is pressed in fullscreen mode, but the hotkey still does not reveal the toolbar, it only seems to toggle the working condition of the double click in the top section.

Is that expected or is there something I need to do to make it work?

Aside: I was not able to see the new fullscreen-on/off hotkey (still used to ) nor the toolbar-show/hide hotkey.
I still think the context menu should list some of the hotkeys, if you are halfway used to some of the hotkeys in v10/v11 and you have a fresh DO setup, you are kind of lost.

Ctrl+N seems to work fine with the full-screen viewer here.

If the menu/toolbar is turned off, then clicking the top of the full-screen viewer won't do anything, as there is nothing to reveal.

If the menu/toolbar is turned on, then clicking the top of the full-screen viewer will reveal it.

Ctrl+N toggles between those two states.

(This is assuming the normal picture viewer is being used. Some viewer plugins may not handle clicking the top in full-screen mode.)

So you confirm that in fullscreen mode, ctrl-n toggles only between the double click at the top to have an affect or not and when the viewer is not in fullscreen, ctrl-n shows and hides the actual toolbar?

Yes. That's all it is supposed to do.

Ok, thanks! o) Unfortunately I'm still puzzled with this.

Is there a special reason the handling is different in fullscreen? Toggling the availability of the doubleclick to reveal the toolbar instead of directly toggling the toolbar does not seem to make any sense at all, but I might be missing something here, so please be kind if I do! o)

(It's only a single-click to reveal the toolbar, nor double-click.)

Because things are different in fullscreen.

Normal windowed mode: The toolbar is either on or off.

Fullscreen mode: The toolbar is either on or off; if it is on it is either visible or hidden.

The command just toggles whether the toolbar is on or off. Visibility in fullscreen mode is a separate matter. To make it visible, you click the top of the screen (assuming the toolbar is on at all).

Thank you. I like the explanation "because things are different in fullscreen". o)

To me this difference is for no reason up to now, still not sure though wether there's more behind this, but it seems to me that clicking at the top to reveal the toolbar makes sense, just as pressing CTRL-N does (which runs a command to toggle the bar after all). But why are both actions required to get the toolbar to show up? The first action (pressing CTRL-N) does not even give any kind of feedback, so knowing that you might have enabled the top section click is like an easteregg or something. o)

But I won't bother you anymore, now that I know about it, I can deal with it. o) It's still kinda hard to explain and also hard to discover yourself and might be difficult for new/others users as well, unless there is something I or we currently overlook.

Ignore the viewer for a moment and consider these scenarios with floating toolbars:

[ol][li]You have a floating toolbar docked to the top of your monitor. It is NOT set to auto-hide. You can see the toolbar all the time.

[/li]
[li]You have a floating toolbar docked to the top of your monitor. It is set to auto-hide. You can see the toolbar if you move the mouse to the top of the screen. If you move the mouse away, the toolbar is hidden again and you can't see it (but it is still there, waiting for you to move the mouse over it again).

[/li]
[li]You do not have a floating toolbar docked to your monitor at all. You can't see the toolbar, because there is no toolbar.[/li][/ol]

In a fullscreen viewer, Ctrl-N is like toggling between 2 & 3.

In a fullscreen viewer, 1 doesn't exist. The fullscreen viewer does not have a mode where the toolbar is always visible. If the toolbar is on, you can click the top of the screen to reveal it, and then you'll see it, and when you click somewhere else it will be hidden again.

Mhh, ah yeah.

I'm not sure I understood completely, but I actually can image floating/docked toolbars to interfere with the fullscreen viewer toolbar, so I think I like this explanation! Thanks for taking the time! o)