GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DOpus 10.0.3.4 bug: crashing when searching duplicates

I encountered a bug in DOpus 10.0.3.4 (on Windows XP (32-bit (x86)) running DOpus in French on a USB-stick) which makes it unusable for me:
When I search for duplicates (especially when I have 2 listers open), DOpus crashes immediately.
I ran the same actions on v. 10.0.3.3 and previous and this never happened. Now it's almost all the time on the new version.

Details:

I ran a quick duplicate search on some files on Windows 7 64 bits and DOpus didn't crash. But it crashed for whatever reason while I wasn't using it! This shows to me that the last version is quite unstable.

Now I tried it again on my Windows XP computer from the USB stick and it crashes most of the time when I run a duplicate search. Is it because I have 2 listers open with several tabs? Because I run the duplicate search inside a library? Because there are network drives connected? Because I run DOpus in French? There may be many hypotheses. There is no crash dump and I do nothing unusual about duplicates.

As for the moment it crashes, sometimes it happens when I just open a new tab and go to the existing Duplicate collection. Or I go into a folder, open the duplicate search panel, set the search on the current folder by MD5 checksum (the other options are set to default), then DOpus would crash when I press the Search button.

At one moment I thought maybe my existing Duplicate collection was corrupted, so I manually removed the Duplicates collection from the DOpus configuration folder, then I restarted DOpus, but I still run into the same problems. For as long as I remember, my Duplicate collection was void at that time.
I even restarted with a new set of options (I removed all the setting files), but this crash still happened to me with the default options.

I'm not doing anything different from what I used to do all the time and nothing significant that I can think of, but I hope this bug will be fixed soon.

N.B.: Jonathan Potter asked me to report problems with the beta versions via the resource centre.

From what you said in the email thread, I doubt the Duplicate Finder is involved in the crash. It sounds more like a problem due to a shell extension or video codec corrupting the process and causing it to crash, or possibly a bug in 10.0.3.4 itself (e.g. there were slight changes to the MD5 code, though nobody else has reported problems so far), potentially triggered when certain files/folders are encountered and processed by the shell extension, video codec or Opus itself.

For tracking that sort of thing down, see these two guides:

Crash, exit or high CPU usage when viewing certain directories:

Crash, exit or high CPU usage when right-clicking certain files:

The first seems more likely, from what you describe, but it's possible the 2nd is also relevant. e.g. If the crash only happens sometime after you right-click certain files or types of files, due to a problem that doesn't always cause an instant crash but corrupts something which later causes a crash.

Although we are not 100% it is the same issue, we have found and fixed a bug which is potentially what has been causing you problems in the Duplicate finder. So it's probably worth waiting for the 10.0.4.0 release, which will include the fix and should be out fairly soon, to see if you still get the problem.

Update: The Duplicate find bug doesn't appear on a specific file or folder (it's on the Duplicate collection as I said before) and I can reproduce it without ever using the right mouse click. Also, following your guidelines, I tried disabling all the plugins and setting "Hide Windows items on file context menus" and turning on context_menu_debug with no significant result.

Following the ideas you gave me, I disabled all the non-Microsoft shell extensions and noticed that if I disable "Nokia Phone Browser", then DOpus would still crash when I run a duplicate search, but at least it produces a report bug. (I had Nokia Phone Browser for ages, it didn't change lately and I didn't encounter this bug prior to version 10.0.3.4. I still use the previous version and run Duplicate find a lot without problems in 10.0.3.3.) So, I was able to send you a few days ago some of the report bug reports and a ShellExView extract with everything except from the Microsoft Corporation. I hope the reports contained the information you needed to track down this bug and fix it, as you said.

10.0.4.0 is out now. Do you still see the problem with that?

I ran a quick test with 10.0.4.0 in the same conditions and the problem seems to be gone now. Thank you!