DOpus 12.20 and Mystic Thumbs

I saw in some threads that people were using Mystic Thumbs to see thumbnail previews of eps and other file types. I installed the trial version and it works great in File Explorer but not in DOpus. I reached out to Mystic Thumbs and they said they've got a number of customers using the two together successfully and asked if there was anything in DOpus settings that might be causing the problem. Any suggestions would be much appreciated.

After playing around further I discovered that once I've displayed the files as thumbnails in File Explorer, they will then display as thumbnails in DOpus. Is there any way to avoid having to do that?

Assuming Mystic Thumbs installs a 64-bit IThumbnailProvider, it should work in Opus the same as in File Explorer.

People have mentioned using it with Opus a few times over the years. There was one report of an update to it breaking things but I don't know if that went anywhere or if it is still relevant (See the thread: Mystic Thumbs).

That means Opus is asking the Windows shell if it can generate thumbnails for those files. It should in turn ask shell extensions like the Mystic Thumbs one to generate thumbs if needed. Once a thumb has been generated (and if it took more than a very short amount of time), the shell will cache the thumbnail for speed. Asking the shell again after that will just retrieve the cached thumbnail.

So it sounds like for some reason Mystic Thumbs thumbnail generation is working in File Explorer and then being cached, and the cached copy is then available to Opus.

I've seen that happen when only a 32-bit thumbnailer is installed, and not a 64-bit one. If that is what's happening, you'd only see thumbnails generated if a 32-bit process was doing it. File Explorer is normally 64-bit, but if you're causing the thumbnails to be generated via a File Open dialog, from a 32-bit program, then that could well be what's happening.


I have been using Mystic thumbs with Opus for quite a while now. It is the only thing so far that I have found to give me transparent background PDF, EPS and Adobe Illustrator files, which is very important to me.

I have had plenty of problems, but I have always found that those probems happen in Opus and Explorer.

I also get problems when I do a major upgrade of windows - as I did last week - hundreds of PDF and Postscript thumbnails vanish leaving just the filetype logo.

The only thing that will get them back is to move the files to another drive and then move them back. It isn't great and I am gathering evidence to take it up with the developer.

Have you tried setting the thumbnail thread number to 1 in the Opus settings? From my experience it is worth a try.

1 Like

Thanks Leo and Auden! I used an option in MysticThumbs to clear the cache, and from there on everything has worked fine in Opus as well as Explorer. I can browse folders with .eps files in them that I hadn't browsed since installing MysticThumbs and after a brief pause the thumbnails all come up just fine. It's a great solution to a problem that vexed me for the last several years, and a great add to Opus. Their support is excellent too.

1 Like