DOpus 9 - right click on 3-button icon strange behaviour

I have these "3-button" icons (LMB: shows content of a folder, RMB: shows a list its sub-folder) It worked perfectly in DOpus 8, but behaved rather strange in DOpus 9 (buttons are imprted from DOpus 8 config file)

When I click RMB, it "flashes" the list of sub-folders, but the list won't stay open, so that you can choose. Instead, the list closes itself, and the source display shows content of the 1st sub-folder. If I keep playing around, right click different 3-buttons. Sometimes, the sub-folder list holds, sometimes it doesn't. I can't figure out the consistency.

The bottom line is that right click a 3-button icons will sometimes give me the list, and sometimes it doesn't.

I do notice one thing though. If I right click and hold the mouse button, I can almost get the list.

I tested the situation on different computers, same behaviour. It feels like something DOpus 9 related.

PS: I don't use any kind of mouse gesture program (never have)

Is this a known bug or something ?

Can you post the actual button? I'm somewhat confused because it sounds like you are talking about a Go FOLDERCONTENT button, but this did not exist in Opus 8.

This problem still exist in v9.0.0.9.

Accidentally, I discovered something new. With the same button, RMB on the right half of the button gives you the problem (ie. flashes a submenu), RMB on the left half of the same button has no problem (ie. submenu holds still).

The button was created using the guide from this forum. Nothing special.

See video clip attached. (Sorry for the poor video quality. I can't get my screen capture / video capture software to capture this. It interferes the behaviour I want to show you. I end up shooting this with my camera)
RMB Won't Hold.rar (825 KB)

As I asked you four months ago, could you post the actual button?

I copied the C drive button into a text file. Is this what you need ?
Botton-C.txt (2.12 KB)

Three-buttons containing menus have never worked very well and aren't really supported.

Opus doesn't offer a "new menu" option within a three-button, but it also doesn't stop you creating a menu somewhere else and then dragging it into a three-button.

I think Opus should either fully support such menus or block their use completely but at the moment you can trick it into trying to combine them. Of course, full support is the nicest of the two options. :slight_smile: