DOpus "blocking" control panel in Win 8 x64

Apologies for the slightly misleading subject. I couldn't think of a more accurate short version. Here's my problem:

Under Windows 8 x64, if DOpus is set to replace Windows Explorer, I can't open the control panel or any control panel apps (such as Personalize or Devices and Printers). They simply don't open. As soon as I change DOpus to not replace explorer, everything is fine again. I know DOpus is not supposed to open CP, but I have never had it stop it from opening on Win 7.

I run DOpus 10.5.2 x64, Win 8 Pro x64.

Check that Windows is not configured to run Opus under any compatibility mode, which can cause problems with Explorer Replacement:

Also make sure Opus is not elevated under UAC:

Reinstalling Opus over the top of itself, and then rebooting, may also help if the problem is with registration/installation. Rebooting is important, don't skip it.

Manually removing the Explorer Replacement settings may also help, though probably only if the problem was due to Windows compatibility settings:

Thanks. Opus is not in compatibility mode and not elevated. As to Explorere replacement - removing this setting immediately solves the problem, but is not the behaviour I'm seeking (Opus has been my file manager for year and I have no desire to go back to Explorer or to make it that little bit harder to open Opus).

If you manually remove the explorer replacement settings (using the .reg file in the guide linked above), and then turn Explorer Replacement back on using Preferences, does that work? That's what I was suggesting, not just turning it off and leaving it off.

Did you try reinstalling Opus over the top of itself as well?

Thanks for the clarification.

I disabled the explorer replacement setting with the reg file and then couldn't re-enable it using the setings (I mean I could change the settings, but it had no effect). One thing I did notice was that when the setting is on, explorer responds very slowly (so win+e takes about 7-8 seconds before an explorer window opens) but if the setting is off explorer responds promptly.

Next, I'll try to reinstall over the current installtion and see what happens.

Unfortunately, installing over the current installation didn't work, so I tried to uninstall and reinstall, but that didn't help either.

Any other suggestions?

How are you launching control panel?

It might be worth installing the latest beta (and rebooting) in case that makes a difference.

I try to launch in several ways, but none work. Usually (because it's easiest) I right click the desktop and choose Personalise. Another way is to type "Control" in the start screen and then click the control panel item.

I'll try the beta, but would appreciate any idea as to why this might be happening.

Unfortunately, the beta doesn't solve the problem. I was a little suspicious that the control panel opens briefly and immediately closes. I tried to detect it by using the task mamanger, but didn't see anything. What now?

Opening & closing is definitely odd, as that suggests that everything Opus does is working correctly, but something is then closing the window just as it opens. (Opus doesn't care about the Explorer window after it opens; all Opus does in this situation is tell Explorer to open it.)

What other software do you have installed? Particularly things which modify the standard window behaviour or look & feel of other apps (e.g. things which add buttons to the titlebars, multi-monitor or window-layout tools, theme/style tools).

Sorry for being unlcear - I cannot say for sure that CP opens and then closes; I suspected that that might be the case, but couldn't see anything to verify it so I could be wrong.

I don't have any system software or utilities installed. This Win8 installation is brand new so I only have about 12 software packages installed, all of which are boring things like Office, Adobe stuff and database access apps.

Now I'm really not sure what is happening.

Can we start again with a clear description of exactly what happens? (Do any windows appear at all, even for a brief moment?)

Please list them as one of them may be relevant.

Another thing which might prove useful is running FileTypeDiag to produce a listing of your Folder registry settings so we can see if anything is wrong there. To do that, please run FileTypeDiag, leave the file extension box empty and just click the Save button; zip up the file it creates and attach it here or send it to me via a private message if you prefer.

Ok, this is what happens: When Opus is set to replace Explorer (any of the replacement options), Control Panel and any Control Panel apps don't open (by "don't open" I mean nothing happens. Please ignore any comments I made earlier - they were just thoughts that turned out to be wrong). Changing the settings back and forth between replacement and non-replacement acts like a toggle for access to Control Panel. The one exception I discovered today was that Control Panel opens just fine using Opus's Tools menu, regardless of the settings.

I will send the list of applications and the FileTypeDiag output in a private message.


Many thanks for the logs!

I compared against my own Windows 8 system and tried re-creating anything that looked suspicious in the registry, and installing any apps I could get hold of which I felt likely be connected, but everything still works fine for me, unfortunately.

One thing to check: If you go to the Help menu in Opus, open the About dialog and click Copy at the bottom, does the text it puts in the clipboard say the OS version is "OS 6.2" on the 2nd line?

Hi Leo,

It says
Directory Opus Pro (4969) x64
OS 6.2 (B:9200 P:2 T:1) SP 0.0

Do I understand correctly that you are lost for further ideas? :wink:

Now that I've discovered that CP can be run from within Opus, I'd consider this matter more of an irritation than a show stopper. However, please do let me know if you have other ideas.


There are one or two other things you could try but we're into diminishing returns in turns of how much effort it'll take to try them.

Maybe if anyone else runs into the same problem they'll be able to add any findings or similarities (e.g. in apps they have installed) to help narrow things down or solve what's going wrong.

Thanks, Leo. Could you tell me what those other things I could try might be, on the off-chance that I'd be inclined to give them a go?

You could grab the SysInternals AutoRuns tool and see if anything else has installed a ShellExecuteHook. Easiest way, on Autoruns' Everything tab, Ctrl-F for ShellExecuteHook. On 64-bit Windows there will be two sections, one above the other. If there's anything but the Opus hook in either section, try disabling it there by unticking it.

The other thing is a lot more long winded: Start from a fresh Windows install and verify that things work as expected (they should unless there's a driver issue or something, since it works on other WIndows 8.0 machines) and then install your other software one-by-one until the problem re-appears. That's hours of work, though.

Thanks. Tried AutoRuns and it's Opus in both entries. Having just gone through a fresh install of Windows, the second option will have to wait until Windows 9 or a new machine come into my life...


I ran into a similar problem in Win7, but was able to get things working OK again after much work.

HKCR\Folders\Shell is extremely finicky. If you have tried to simplify your right-click menus by making changes in any of the items there, that could be the problem. My problem was partly in OpenInDOpus and also some of the other non-Dopus items, and it took a lot of trial and error to get things back to the point the Control Panel and the Recycling Bin would work again.

Use of the Extended value or the ShowOnlyInBrowser value in places where you didn't originally find them may be part of the problem, if you experimented with that. The problem can come from any item under this Shell, not necessarily ones that are strictly Explorer or Dopus.

A problem here is that Windows doesn't give the user control over menu content without interfering with Control Panel and the Recycling Bin displays. Some of the menu clutter just can't be removed.

Not sure if that's what you ran into, but sounds like the same thing I encountered.