DOpus disabled by Sophos

The other day when I tried to run DOpus, a box popped up that said something about DOpus failing a checksum and might be infected or corrupted, it would be disabled, and I should download and re-install the latest version. I did so, but DOpus would not run. A Windows error said, "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." Even the DOpus shortcut on the desktop after the re-installation was just a generic icon, not the DOpus icon. Multiple uninstalls (usually with errors), re-installs to different directories, permission settings, etc., had the same result.

After considerable troubleshooting, interactions with GP's tech support, and my local IT guy's work, the problem turned out to be the Sophos anti-virus installed by my company. It had decided that DOpus was acting suspicious and shut it down. Now we just have to figure out how to get Sophos to play nicely with DOpus.

Does Sophos report why it is shutting down Opus in a log somewhere?

That may suggest a feature to disable (e.g. global hotkeys can look like a keylogger to some a/v tools but can be turned off if needed) or may indicate that Sophos is having a false-positive about a particular virus.

Unless there really is a virus on the machine it should be reported to Sophos either way so that they can remove the false-positive, but if we can work out what's triggering the false-positive then you might be able to get Opus running sooner rather than later (or it might help Sophos solve the problem).

Sophos never reported a problem; that's why it was so hard to track down. We haven't been able to track down any kind of local log. It is also set up to not let the local user have any control, so our local IT guy is working with the corporate folk to try to figure it out. That may take a while.

Maybe Sophos was triggered by Directory Opus phoning home? It does this regardless of user update check settings there is no phone-home provision in the license agreement that I'm aware of. Is that even technically legal? Are there any examples of legitimate applications which phone home without mentioning it somewhere in their license agreement?

Or maybe screen mates type code which might be run by Dopus without a proper way to shut it off if you modify certain files.

Anti-piracy methods are one thing but in my opinion it doesn't makes it okay to deceive your customers. It is also definitely not professional to generate an 'error' telling a customer their software might be compromised and then run something like a screenmate program.

Programs of those nature are usually are flagged by scanners.

Whether or not things like these is causing the issue posted above, I hope the developers decide to use more professional methods in the future considering the price tag on their software.

Okay I'll stop ranting now... Have a good day guys!

Opus doesn't "phone home" except to do the update check, which you can turn off. What exactly are you talking about?

I also use Sophos and it plays just fine with DOpus.

Are you talking about anti-virus or firewall? You say anti-virus, but Sophos comes with a complete bundle of both.

In the firewall area, I have DOPUS.EXE as a recognised trusted application.

It is also one of the recognised "Processes".

The anti-virus bit has never objected to DOpus.

I assume that you have turned the firewall and anti-virus on and off to confirm that this really is causing the problem.

Thanks, all. In answer to some questions, the whole Sophos package is installed on my machine. We disabled both the firewall and antivirus to confirm that Sophos was the problem. I don't yet know what caused Sophos to shut down DOpus after they had peacefully co-existed for months. Interestingly, we re-enabled Sophos after DOpus was running again and DOpus is still working -- at least for now.

Now that we've figured out that it was Sophos, we'll get it solved. I just posted the original message in hopes of saving someone time and frustration if they encounter the same strange symptoms -- like Windows refusing to run DOpus and the DOpus shortcut and executable file icons changing to generic ones.

I have a vague memory of Sophos putting out a major update recently. One of those that required a full reboot to work. Perhaps that explains the recent onset of your problem.

One of my machines has been playing up on the Sophos update front in recent weeks, which I suspect may be down to this update.

I should have added that I have the Sophos/DOpus duo running on two PCs and a laptop. Two Vista one XP. No problems with any of them. So it can't be a common issue that Sophos will have seen a lot.

I find the Sophos support people to be pretty good. One advantage of this package is that it is really only widely used in the corporate environment, so it does not have the same need to support millions of end users. So they can support via email.

Someone asked about logs, if you haven't tracked it down yet, by default, Sophos keeps its log in the file SAV.txt.

C:\ProgramData\Sophos\Sophos Anti-Virus\logs\SAV.txt

Possibly hidden, but easily approached with DOpus.