DOpus doesn't install x64 version on Windows ARM in Parallels on Apple Silicon M1

I was very happy to see DOPus running on my M1 mac with Parallels and Windows ARM. Windows ARM has x64 emulation and it works great, I have several x64 windows programs running. However the universal DOpus installer always wants to install x86. It works nicely, but I would prefer x64. Compatibility settings of the intaller do not offer any switch to change that. Could you please for example offer a switch for command line that will force x64 installation? Thank you!

I would like to add that other universal installers all automatically chose x64, it was only DOpus that didn't.

I don't think there's a simple way we can do that. Inno Setup seems to need to be told what architectures to install the 64 bit files on in advance. We could tell it to do so on arm64 but as far as we know x64 support on ARM is still in beta so this would mean it wouldn't work for anyone who wasn't using the Insider build. Once x64 support is out of beta we'll be able to change it so the x64 files are installed automatically.

Hello, just for your information, DOpus x64 (!) seems to run with no issues on my MacBook M1. I tend to be very careful and since I'm not 100% sure if it installed absolutely perfectly, I'm deleting the (cloned) VM and will continue to use the 32 bit version.

In the 12.24.3 beta we've changed the installer to install the 64 bit version on ARM systems as an experiment. Please let us know if it works OK as we have no way to test this ourselves.

Has anyone tried out this change in the recent betas?

We've had zero feedback, and can't test it ourselves, so we're considering undoing the change before the next stable release.

If you want the change, please try it out ASAP and let us know if it works or not.

I will do testing within one hour!

I did not receive the notification about Jon's post. I double-checked my e-mail backups, I got no notification.

I have the suspicion that perhaps one does not get notification if the browser tab with this conversation is open and auto-loads after a browser start without the user actually reading the new posting, but the forum software thinking one did due to the reload. But that is just speculation, it would have to be tested. If my speculation is the case, I wonder if it is possible to trigger "is-read" information by the user scrolling to the latest post. - It is relatively unlikely that the post notification got eaten by anti-spam, I use a very low false positive anti spam spam software that I can only recommend (server side, (Cyren / Eleven Expurgate))

I backuped my configuration, uninstalled Directory Opus, restarted, installed the beta, installed my certificate, restored my configuration (using the "ALL configuration data" option).

RESULT: Directory Opus shows as 32 bit in Taskmanager and in the ABOUT windows it says x86. Everything else worked.

Thus x64 is NOT installed with the new installer. Please refer to a private message about the installer I am going to send to Jon and Leo now.

For your information, I installed via Directory Opus 12.24.5 (Beta) via
it must thus have been 12 24 5 beta, I did not explicitly check the exe but I it must thus have been the 12 24 5 beta.

Many thanks, and for the extra info via PM.

Looks like it's more complex on the installer side than we thought. We'll need to investigate in more detail when we have time.