DOpus prevents Oculus installation

This is a weird one.

I tried to install Oculus over the weekend, and it kept failing. After some Googling, I found a mention of DOpus being the cause. So I closed DOpus, opened Win 10's File Explorer, and restarted the Oculus setup file. Lo and behold, it completed the installation.

My DOpus version is 12.23

So simply launching the installer from File Explorer instead of Opus solved things?

That would either be due to your antivirus blocking Opus from running the installer (try disabling your antivirus to test that), or the installer not loading DLLs properly if the current dir is removed from the search path (try toggling Prefs/Misc/Advanced/Compatibility: dlldir_security, then reboot to test that).

The Antivirus (Norton) was disabled when I ran the installer. When I encountered the first failure, I checked the setup log and there was something along the lines of not being able to create directories.

As it appears to be the exception, i .e. no-one else reported it, I can only assume that it is a local issue. I will revisit this post should it happen again.