GP SoftwareTwitter
Opus FAQsManualCommandsObjects

DOpus slow to load Google Drive File Stream folder with many items

I use Google's Drive File Stream to 'mount' my Google Drive Shared Drives on my Win 10 PC. One of the folders on one of the drives contains 11k+ sub-folders.

When I open this folder in Explorer, there's a tiny delay, and it shows the contents. Same with Total Commander (x64).

When I try to open this folder in DOpus, it perpetually shows 'Reading folder' with a progress bar. Several minutes later, it's still showing the progress bar. Second attempt now.

Since the folder loads without issue in Explorer and TC, I imagine this is an issue with DOpus's handling of the 11k+ subfolders in this folder.

In any case, is this fixable?

EDIT: Same thing happens in another folder which contains less than 1k sub-folders.

If you send us some process snapshots we can see if it's getting stuck somewhere within our code or Google's (or someone else's).

Before I do that, are there any settings that I could toggle to potentially disable DOpus from trying to read data/metadata/whatever from each cloud-hosted folder?

Small bit of additional info: When I open a folder on the same Google mounted drive which contains 12k files for the first time, there's no lag.

EDIT: sent dumps

As a test, if you turn on Preferences / Folders / Folder Display / Show generic icons for... and set it to ...all folders, does the slow-down still happen?

As a second thing, it looks like a column like Description is turned on (or you're in thumbnails or tiles mode, perhaps) which is causing Opus to inspect all the file contents (since it shows information like image width/height that requires opening files to calculate). That's probably not desirable in a cloud storage folder, although I'm not sure if it's involved in the main issue or just making things slightly slower.

Yes, still happens.

No, just name, size, date, as per my screenshot. Are you basing that on the dumps I emailed?

No, in detail mode

Another small update: I did notice that the 1k sub-folder folder is loading after a short while now, whereas the 11k sub-folder folder is loading after maybe five or ten minutes, not sure exactly how long, I wasn't watching it.. This is before the preferences change you suggested.

Again, there's no such delay in Total Commander and Explorer.

Does it make any difference if you turn off Preferences / Folders / Folder Display / Display localized folder names ?

1 Like

@Jon Yes! That makes it load instantly. What does this mean?

From documentation:

Display localized folder names : Vista introduced the concept of localized folder names. In Windows XP, the C:\Program Files directory (for example) is physically renamed in other languages - e.g. on French systems the folder is C:\Programmes . In Vista and above, the folder is always called C:\Program Files , but its name is translated when it's displayed in the user interface. With this option on Opus will display the localized name for such folders instead of the real name in the filesystem.

So just keep it turned off I guess, if you're using Google Drive File Stream?

Thanks for that feedback and the dumps which gave us the idea to try turning that option off.

What does this mean?

That Google Drive File Stream has a bug in it :slight_smile:

So just keep it turned off I guess, if you're using Google Drive File Stream?

For the moment yes, but we might try changing something in the next update to retrieve the localized folder names in a different way - so maybe you could try turning it back on then as a test?

Sure! Always happy to help test.

Thanks! The new beta is out now.

To test the alternative methods, please turn back on the Display localized folder names option.

Also please verify that you still get the slow down in the default state before proceeding.

Add a DWORD value to the registry under HKEY_CURRENT_USER\Software\GPSoftware\Directory Opus called LocalizedNameTest. Set the value to 1 and see if that affects the speed of reading the Google Drive folder.

Then change the registry value to 2 and repeat the test.

@Jon K, so..

  1. Installed 12.20.3
  2. Ensured Display localized folder names is enabled
  3. Tried loading the folder

Result: issue not fixed :x:


  1. Disabled Display localized folder names again

Result: issue fixed :white_check_mark:


  1. Enabled Display localized folder names again
  2. Closed DOpus
  3. Added DWORD LocalizedNameTest and set to 1
    image
  4. Open DOpus

Result: issue not fixed :x:


  1. Closed DOpus
  2. Changed DWORD LocalizedNameTest to 2
  3. Open DOpus

Result: issue not fixed :x:


In short, looks like neither method worked.
It should be noted that:

  • I didn't close the registry editor between tests
  • I didn't restart Windows between tests

If there's anything else you'd like me to try, let me know.

Sorry, meant to reply to say thanks for doing the tests - they were useful even if it might not look it :slight_smile:
We will try a different approach in the next update.

1 Like

Hi, could you please try this test version and see if it's still slow with Display localized folder names turned on?

Thanks!

1 Like

Installed and the issue seems fixed with Folder Display > Display localized folder names enabled.

:+1:

2 Likes