DOPUS very Slow Startup, Slow to list NAS

After doing a system restore on win 10 Dopus is extremely slow 30 seconds plus to list a folder on the nas. I've been using DOPUS with no issues for years until now. I have downloaded the current version of Dopus and installed it. SMB to NAS works fine and fast in windows explorer.

not confirmed
win 10/Do 13 and nas are faster than win 10/Do 12.
same under win 11

which manufacturer/NAS type is used?
System recovery done with what?
which windows 10? (home/pro) and current state of 22H2?
at pro there were recently some changes, many things do not work properly anymore!

which manufacturer/NAS type is used? Qnap TS453D Latest Firmware/Software 32GB Ram Raid 5 14.5 TB Free Space
System recovery done with what? Acronis Backup from WinPE with latest full backup
which windows 10? (home/pro) and current state of 22H2? Running 21H2 not 22XX, Win 10 Pro Workstation Version 10.0.19044.2486
at pro there were recently some changes, many things do not work properly anymore!

qnap, see if anything has been changed in smb.
which acronis? (single, company, true image, cyber backup/protect)
for your 21h2 microsoft support has expired since 10/01/2023 and for the last 21h2 on 13/06/2023.
the 21h2 (released 23 months ago) could therefore be the cause.

I meant to say Aomei Backerupper Acronis is what I use on my webservers.
I turned SMB v1 off on windows and it killed all smb connections. I had to re-enable SMB 1. Powershell reports smb2 and 3 enabled, and The qnap has smb version 2 and 3 enabled.

Again, SMB via windows explorer gives instant response to any resource on the NAS

That's what I'd focus on initially, as I wouldn't expect things to still be depending on v1 and it suggests something may be stopping v2 from being used. It could also mean that some operations keep trying v2, failing, then retrying with v1, which could slow things down.

Tried rebooting after disabling v1?

Anything that looks relevant in Event Viewer under Windows Logs / System (or Security)?

If they're mapped drives (not UNC paths), try disconnecting them all, and then re-mapping them.

Make sure antivirus (and similar) is up to date and working properly, as they'll get involved in all filesystem requests.

Opus ultimately just asks Windows to get a list of files in a folder, and doesn't talk to the NAS directly, and hasn't changed how it does things in a long time, so something on the system must be functioning differently if it was working before the system restore.

1 Like

when was the backup created.
when was it restored.

via which option was it restored:
internal options (program),
at system start (boot menu),
started via usb-stick/cd

could be a defective Dopus confi!
test after reset to factory settings.

The only Opus config option that affects how long directories take to list is the option to sort links to folders like folders.

If the link target is unreachable, it can cause a long delay. (Opus 13 will display a message if that’s happening so you know what it is, but Opus 12 doesn’t do the same.)

(Well, that and scripts that react to folder changes, if you have any installed.)

Thank you that was it. I found it by elimination. I tried first to restore a backup of the config, but it still acted up, so I deleted the entire install, and wiped the registry entries and all remaining files after the uninstall. Then installed it clean and it runs like a champ. So I have begun building a new config by recreating my settings and it is running great. It was the long way around, but it's a fix.