Double click brings up DOpus...but NOT when I click folders

Here's an interesting problem. I recently purchased my license to Directory Opus 9 and made it my primary file manager by going into the Preferences and setting it up via the Launch options.

When I double click the desktop...DOpus starts as promised and it's working perfectly. I'm using a laptop (Dell Inspiron 2200, 512 mg of RAM, XP Home Service Pack 2) However, I also have shortcuts I've set up pointing to directories I use frequently...and when I click on these shortcuts now...instead of DOpus taking over...I get Xplorer2 instead.

Let me back track and explain. Before I purchased my license to DOpus previous file manager was Xplorer2. Not a bad file manager...but it is blown away by DOpus. So before I had purchased DOpus...I had set Xplorer2 to be the primary file manager and had this shell open those folder shortcuts.

What I don't understand is why after installing Directory Opus 9 and setting it up to be the primary file manager to handle all recommended folders in the Launch options...Xplorer2 is still launching those file shortcuts.

I'm experienced enough to go into the Windows Registry to make manual I'm mystified why DOpus doesn't take over here. I'm assuming the programmers to DOpus "assumed" only Windows Explorer was the primary file manager before being called to replace it in its stead. It appears to me they didn't take into account there could be "other" file managers out there manually configured to being the primary file manager replacing Windows Explorer.

I tried to manually go into the Windows Registry and fix this problem...but instead of fixing it...I ended up losing my DOpus double click desktop feature and had to reinstall DOpus to get the double click desktop feature back.

Can somebody please issue a zip file with the correct registry settings that DOpus will recognize so it can take over as file manager. Remember, I already set up DOpus as primary file manager. But for some strange previous file manager, in this case Xplorer2, is still stubbornly launching the folder shortcuts that DOpus should be opening instead.

Thanks in advance.

If you have turned on the Explorer Replacement option in Opus then when you right-click a folder (say on the desktop) you should see it has a option called "Open in Directory Opus" which should also be bold indicating it will be double-clicked.

Are either of both of those untrue? (And is Explorer Replacement enabled?)

I don't know how Xplorer2's replacement system works but I'm guessing it is along the same lines (or it replaces the "Open" action but even if it does Opus should make the "Open in Directory Opus" action the default).

It is possible that Xplorer2 is repairing its settings when something else changes them. I don't know if it does but some programs do that with their filetype associations.

Presumably Xplorer2 has an option to disable its replacement system. Have you tried turning that off, then telling Opus to take over the folder associations again? (In Opus, turn off Explorer Replacement, then close and re-open Preferences and turn it back on again. That should force the registry settings to be re-created even if Opus doesn't think they need to be.)

I tried the right click option to see which context menu item is bolded...and it's STILL Xplorer2. Here's the problem...Xplorer2 does NOT have a built in option like DOpus has in giving the user the ability to check off a dialog box allowing the program to either be the Windows Explorer file manager replacement or not.

Instead...the programmers to Xplorer2 gave instructions tucked away in a .txt file in the installed directory telling the user how to make Xplorer2 the default file manager. But here's where the problem comes in...they offered this option: launch Windows Explorer - go to Tools/Folder Options/File Type and select Folder in the list and then "Advanced". This opens up the dialog box to browse the options available and select "Open with Xplorer" and make that the default.

THEN...they offered this...assuming the user is advanced enough: go to Start/Run and type "regedit" and hit enter. This opens the Win Registry. They give this instruction: Go and find THIS:


They tell the user to right click the default value in this registry setting and then enter "@="open_X2". However, I learned from trying just this option that it did NOT make Xplorer2 the default file manager. It turns out there is ANOTHER registry settings they failed to mention...and I discovered this to be:


When I edited THIS registry setting as well as the one they DID mention above...then Xplorer2 immediately became the default file manager whenever I opened file folder shortcuts.

Now, granted...this deep Windows Registry entry editing did the trick to make Xplorer2 the default file manager before I purchased my license to DOpus 9...but as I don't see any mention in the DOpus help file how to do THIS kind of registry editing to ensure it replaces any OTHER file managers that is set up...I assumed your simple file manager preference setting would take care of this annoyance. It doesn't and the preference option does not take away Xplorer2's default action on folder shortcuts on my desktop.

You know how whenever you install a new browser to handle HTML file extensions...whenever you launch the other warns you some other program has taken over this setting and asks you if you want it back? This setting is not CURRENTLY available in DOpus 9. (At least as far as I can see.)

It would be nice if you include an update that looks at the registry settings to see if DOpus is CORRECTLY set up to handle file folder shortcuts on the desktop and allow the user to be warned if there are "irregularities" in the Win settings and DOpus can fix the problem. As of right now...I don't think any other fiddling would be advisable from my end because I'm satisfied as it is that I can double click the desktop to get into DOpus...and I'll just have to settle for Xplorer2 opening up those file shortcuts.

It would be fairly difficult for Opus to automatically preempt/correct every possible way that someone (or some other program) could mess around with their registry, and the standard ways of taking over the folder associations should already be undone by what Opus does already.

If you can work out any specific registry settings that Opus should change/remove to solve the problem then by all means let us here at the forum know (or let GPSoftware themselves know directly) but without access to your machine it's pure guesswork on this side.

I think the correct thing to do is get everything back to normal so that Explorer is the default -- i.e. undo everything that you did to make Xplorer2 the default -- and then tell Opus to take over.

If you want details of what Opus writes to the registry to take over the folder associations have a look at this FAQ. It's about manually undoing the settings but you can infer what they are from the descriptions of what to remote.

Oh, one possibility is a permissioning problem in your registry which is preventing the keys referencing Xplorer2 from being changed. Attempting to change them manually should answer that question (Vista/UAC issues aside).

There could also be a mismatch between what's in HKEY_LOCAL_MACHINE\Software\Classes and HKEY_CURRENT_USER\Software\Classes for the Folder filetype but that would seem odd as Opus writes to HKEY_CURRENT_USER which should take priority over HKEY_LOCAL_MACHINE. Still, there could be a strange combination of settings that I am not thinking of which is also not easy to see if you are looking at the merged view of the two Classes hierarchies under HKEY_CLASSES_ROOT.

There is an advanced option in Opus called global_explorer_replacement (type that into the Preferences filter box to find it quickly) which makes it write the registry settings to HKEY_LOCAL_MACHINE instead of HKEY_CURRENT_USER, and I think also uses a slightly different method for them, but I wouldn't recommend messing with this as it will probably only complicate things more than they already are. (Unless you have already messed around with that setting, in which case try turning it off.)

That's all I can think of at the moment. All I can do is guess without physically sitting down at your machine's registry.