Double-click no longer working (Wacom / Windows Ink)

I have DO 12.24 Pro installed on two systems; an Alienware laptop running Windows 10 and an old tower running Windows 8.1. Until a few days ago OP has run perfectly on both systems.

My work relies on being able to use my scanner. Microtek no longer supports it nor offers a replacement, and it cannot be made to work with Windows 10, so I am stuck with running Windows 8.1 on the old system.

The old tower has an even older monitor connected to it. I found a good deal on a refurbished monitor and decided to upgrade the old one. However, that required a new graphics card. My computer guru had an appropriate card in his shop on another machine. I had that card installed on my tower. Everything works perfectly with my old monitor (the new one arrives Tuesday) except DO.

Double-clicking on items opens them normally EXCEPT graphics files or video files. Double-clicking on any one of them freezes DO for several minutes, preventing even closing DO. The freezing of DO has no effect on any other application.

If instead of double-clicking on a graphics or video file I right click on it, I am presented with my options. If I click on Open, the file opens normally in my default application. If I click on Edit, the file opens normally in my default editing program.

I have viewed the DO settings and do not have "Single click to open an item" checked. Although I do not have the new monitor installed yet, I do not expect it to make any difference to DO.

Which types of image and video files is the problem happening with?

Can you share a small example?

Is the Opus viewer being opened, or something else?

Is the viewer pane open while doing this? (If so, do problems happen when the files are selected without being double-clicked?)

What happens if you double-click the same files in File Explorer?

Please link your account: Directory Opus Resource Centre

Thanks for your reply Leo.

"What happens if you double-click the same files in File Explorer?"

They open normally and promptly.

"Which types of image and video files is the problem happening with?"

.jpg .tif .CR2 .MP4 .flv

In folders with predominantly those types of files I set the folder view to Thumbnails.

I just tried an experiment and set one of those folders to Details. After doing that, the same files opened normally when double-clicked. I then set the folder view to Details + Thumbnails. Again, double-clicking on one of the .JPG files opened it normally.

Resetting the folder back to Thumbnails view caused double-clicking to fail again.

If you still wish a sample file (a small JPG) i will attach one to my next reply.

Do you have any scripts installed? One may be changing what happens when you double-click in different display modes. That's about the only thing I can think of which would do that.

Howdy Leo,

I haven't created any scripts, but to be sure, where would they be stored? I've basically been copying my settings from iteration to iteration, and something may have been carried over. The oldest versions I still have on file are 8.0 and 8.2, although the oldest registration I have is from 2003 for DO 6.1.

I do not have any DO File types set. No settings in File Display mode looks like it would be causing the problem, and I have the same settings for both the laptop and the old tower, although the old tower is running Windows 8.1 and the laptop is running Windows 10.

Thanks for your help.

Preferences / Toolbars / Scripts in the UI, or the /scripts folder alias will take you there if you want to look at the filesystem level.

File Type events are another thing that could override double-clicks, and could be testing the display mode. I hadn't thought of that before. But if you're sure you haven't changed any then it can't be that.

I can't think of anything else that would do this, at least without third party tools being involved and doing something weird, and assuming that the machine isn't under heavy CPU or disk load when in thumbnails mode. (That could slow things down a lot, and might be caused by something like a video codec going wrong.)

Just had a thought: While it's frozen, you could make some process snapshots and send them to us, and we may be able to tell what's going wrong from there.

I made the process snapshots and created a Zip file of the five files. The file was huge, so I used your WeTransfer link. I received the following notification from WeTransfer:

"Files sent to

1 item, 390 MB in total ・ Expires on 29 June, 2021"

Please let me know if there is any problem with your receiving the dump files or my creating them

The snapshots are all of DOpusRT.exe, which won't be involved (unless the problem is desktop double-click not opening new windows).

Could you make some snapshots of DOpus.exe while the problem is happening?

Thought that's what I did. I double-clicked on an image. DO froze, then I made the snapshots. Should I create them differently?

You created snapshots of DOpusRT.exe not DOpus.exe.

2021-06-22 17-00-30 Clipboard Image

I right-clicked on dopus in the Processes column, not the Details column. WinZip is making a new file now from the correct column. I'll send it via WeTransfer when it's finished.

Based on those snapshots, it looks like something has made it so that new threads can't start in the process. I can't tell what, but these components are loaded:

  • Adobe CoreSyncExtension
  • SnagIt Shell Extension
  • Autodesk AcSignCore
  • Microsoft Raw Codec
  • Microsoft WMV Codec

Since it only happens in Thumbnails mode, I'd suspect the last two as most likely to be involved.

Have you tried disabling all viewer plugins? That would stop the Microsoft Raw Codec from being loaded, at least*. Preventing the WMV codec is harder, unfortunately.

(*Unless it still comes in via thumbnail requests to the Windows shell, which are hard to avoid.)

I would look into whether the problem only happens when certain file types are in the folder, which may narrow down the cause.

Edit: Antivirus and similar tools are also always a possibility for causing weird low-level issues like this. I'd also check the Windows Event Log to see if there's anything in there around the time of the freezes.

1 Like

Fixed it!

My new monitor arrived yesterday afternoon. I installed it last night. No change to the double-click problem, as expected.

This morning I tried playing a game of freeCell to check out the new system. The game didn't freeze, but double-clicking cards didn't work. This led me to believe the problem wasn't within DO.

Since Windows 95 I've been using a digitizer tablet rather than a mouse. Back then a Kurta. Some couple of years later a Wacom. The one I use with the old tower system is a Wacom Intuos 4. It comes with both a digitizer mouse and a pen. I'd always used the pen, so I thought I'd try the digitizer mouse.

Surprisingly, Double-clicking worked as it should. Switching back to the pen, double-clicking still froze DO.

I remembered years ago there was a problem with Wacom and a Windows setting. There was a preferences setting within Wacom properties that corrected it. I went searching for the setting and found it.

Use Windows ink

It was ticked on. I unticked it and saved my settings. Suddenly double-clicking worked properly with the pen again.

Thanks for all of the time you spent helping me with my problem. I hope this solution helps you sort this all out for any future users.


1 Like