Double-Click on Desktop starts activating on single click


I just started using Windows 11, and the first thing I've noticed is every click on the desktop background will open a new lister.

After a reboot, it takes a double-click to open a new lister, as expected, but after a while, every click starts opening a new lister.

I installed DOpus first, and it was only after installing Office 2019, and Acrobat PDF Reader that I noticed the new behaviour.


So single-clicks on the desktop start opening new listers a while after boot?

Once it starts happening, is it like that until the next reboot, or does it come and go?

Are double-clicks happening from single-clicks anywhere else in the system?

Have you installed mouse drivers or are you using the ones that came with Windows?

That is correct.

Its consistent until the next reboot

Not that I've noticed. Its a new install, and I've been installing all my usual tools. I've not noticed spurious clicks elsewhere.

Generic windows drivers only. The mouse driver is the generic microsoft "HID-compliant mouse".
It did prompt me to install the awful logitech support tools, which I ignored.

As an aside, I

  1. Killed dopusrt.exe (ensured no opus executables were running), relaunched dopus, verified a single click started dopusrt.exe, dopus.exe and opened a lister.
  2. Killed dopusrt.exe again, renamed the gpsoftware/directory opus folder, relaunched dopus and verified a single click launched a vanilla lister.



Killing and re-launching explorer returned double-clicking to normal.

For that to be happening, a double-click event must be being sent to the desktop window.

Why that would happen on a single-click, I don't know. (Unless the mouse or mouse drivers are faulty, which does happen when mouse buttons start to fail, but would be seen in other places if that was happening.) But if something in the system is saying a double-click happened when only a single-click did, the problem has already happened before the point that Opus becomes involved (when dopusrt.exe handles the double-click event that shouldn't have even existed).

It's possible some other tool is hooking the desktop window and not forwarding the events to other hooks properly.

Anything is possible. DOpus was one of the first things I installed (and desktop doubleclick worked normally initially).

I can't tell if double-click behaviour changed as a result of time, or as a result of something I installed
and unfortunately although it will happen after a while on each reboot, I can't find an app or action which triggers it. In addition, once I killed and restarted explorer.exe, it didn't seem to reoccur.

I forgot to mention that I previously installed windows 11 (about a week ago) and when this started happening it was the icing on the cake of disappointment that Windows 11 is, and I reverted to windows 10 for a while. Both times, I think the last thing I installed was office 2019... I'll see if I can be bothered doing it again. Both installs were fresh installs from the CD, disk was formatted.

I'm running windows 11 on 4 Pcs. Opus and Microsoft 365 is installed on each one of them.
None of them shows the problem mentioned above.

Note: I clean installed Win11.

Have experienced too, after upgrading to Windows 11. Single click on desktop launches DOpus. Had to disable the activation from desktop completely due to this.

1 Like

It doesn't happen for me on Windows 11.

It's probably triggered by installing something else that hooks the desktop or mouse in some way, but working out what's doing it may take some trial and error.

Here's a short screen capture of my desktop and Spy++ logging the mouse events - if it helps in any way.

I selected only to log the core mouse-related events, but if you have suggestions on some other logging schemes, I can try providing additional data.

You should see WM_LBUTTONDOWN before the WM_LBUTTONUP (unless that was just missed from the filter).

Although it is interesting that when I try it, the second click only produces a WM_LBUTTONUP, with no button down and no double-click either. That may be due to how Spy++'s hook interacts with our hook, perhaps.

Couple of thoughts/questions:

  • If you use Spy++ to check the window class on the desktop window, what does it report?

  • Have you turned off icons on the desktop, or turned on the Windows 11 widgets feature, or anything like that?

I've reproduced the problem now. It's a ridiculous bug in Windows 11 itself.

  • First, icons need to be turned off on the desktop.

  • If you've rebooted since turning them off, everything works until you right-click the desktop the first time.

With those conditions met, Windows starts sending two clicks to mouse hooks for every click on the desktop.

We'll have a workaround in the next Opus beta.

Until then, you should be able to avoid the problem by turning desktop icons back on (or avoiding Windows 11 entirely, of course).

(Note that you will may need to reboot after installing the coming Opus update with the change for it to start working. EDIT: Looks like a reboot isn't required, from further testing.)


Thank you! I thought I was going mad!

I totally forgot about the "Turn off desktop Icons" . Its the first thing I do on any new install without even thinking about it.

If turning the icons back on solves the issue in the mean time, I can live with that.

1 Like

FWIW, I see a WM_LBUTTONDOWN on line 1. It's way at the end. Or is that something else?

Just to confirm, turning the icons back on immediately fixes the the problem (no reboot or explorer restart required).

For now I've decided to go with option 2 until I can resolve some other shortcomings and compatibility issues with windows 11.

The reboot will may be needed for the fix in the coming update.

It's not needed if you turn desktop icons back on.

(EDIT: After further testing, it looks like a reboot after the update probably isn't required, but would be worth a try if the issue continues once the Opus update is installed.)