GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Double clicking image opens folder instead of viewer

I've been an OPUS user for a long time, starting with the Amiga and for many years the PC.
My problem is the internal image viewer works with images in folders on my "C:" drive, but not oimages in my "P:" external drive.
I did use the Preferences/File Operations/Double-click on files and the box is checked for using the internal picture viewer for recognized files.
Under Advanced "viewer_disable_internal" there is no value there.
I tried playing around with File Types, and that may be where the whole issue lies, but I'm not sure what to do there, and as I said, the internal viewer works on pictures on my "C" drive, "E" drive, but not the "P" drive. That drive is external, whereas the "C" and "E" drive are internal if that makes a difference.
Any help straightening this out would be appreciated.
Thank you.

The viewer should treat all drives the same, at least if the drive has a letter and is accessible in other software.

When you say it doesn't work, what happens?

What kind of files are you double-clicking?

I used the "open with" and then "select app" and those chose Opus, and also checked "Also use this app for opening these files," (wording may not be exact).
The icons changed in front of the files to the Opus icon (these are .jpg files).
When I double click on the .jpg, the top bar of the window, which shows what folder I'm in, flashes, but the .jpg does not show. This is the "P" external drive. With ALL of my other drives, external and internal, the OPUS viewer works. I tried loading an image from each named drive.
Very strange.

ALAN

You should choose d8viewer.exe and not dopus.exe.

(This is for using the viewer from outside of Opus. From inside of Opus, there's a simple checkbox in Preferences / File Operations / Double-Clicks on Files.)