Dragging/moving left/right scrollbar while directory gets refreshed


I stumbled upon this strange behaviour in a lot of Directory Opus versions, but I was always too lazy to ask for it...but now I'm fed up with it:

Let's assume, a DOpus Lister is empty and an external process generates files in its directory it is currently showing. The slider will appear...sooner or later (you could also use the "Find" function to search for * files on C:). Now try to move the slider up and down. On my workstation I always loose the slider again and again...and again...as long as the directory doesn't get refreshed anymore.

Is that a bug? Or can it be configured? Am I the only person suffering from that issue? I tried to reproduce that in the Windows 7 explorer and it's working there without any problem.

Thank you for your support and information!

Best regards,

Do you mean the scrollbar on the right of the window?

What do you mean by "losing" it? It disappears, or it acts like the mouse button was released and you have to click again?

Leo, you are unbelievable...fast...as every time.

Yes, Leo, it acts like the mouse button was released and I have to click it again. In Windows 7 it's common that the scrollbar is moving as long, as the button is pressed (of course the distance between scrollbar and mouse pointer must stay in a defined range). That's NOT the case with Directory Opus 11. It gets stuck and I have to move the mouse to the scrollbar and press the button again. Then the "connection" gets lost again and the slider doesn't react anymore on my mouse movements.

Do you know what I mean?

1 Like

Is it not reproducable on your side?

I think we can see it, although it's rare here and we had to create an artificial test to make it happen.

We might be able to delay processing of changes while the scrollbar is in use, but haven't tried it yet.

This will be fixed in the next update.

@Leo + @Jon , thank you very much!

I'm really curious whether it's the same issue, because I can reproduce it with my notebook in 100% of the tries.

The change is in 12.14.1 beta if you want to try it. Or do you mean you still see the problem with the beta installed?

It's the notebook of my company and we don't have a license for 12.x. AFAIK using both versions in parallel is not working, right? That's why I didn't test it yet. As soon as IPv6 support is added for sftp, I will convince my team leader to order new licenses.

OK, now I'm an official Opus12 user. This issue is fixed now! Thank you!

1 Like