Drive changes

This Pc

This section does not update with the external drive update works fine in windows explorer.

What I mean is the icon does not get added to the screen you have to select another directory and then back again to get it to show up. Before it used to show up in This Pc without having to do anything once connected to PC. I'm on windows 10 latest build. Not a big issue, but all settings are correctly set. Must be the new beta update has done something .

F5 should refresh things without needing to change folders.

Make sure Opus isn’t being run elevated (UAC / run as admin), as that can block the drive notifications from reaching it.

We’ve also seen devices that don’t trigger the notifications correctly, in any program, and that File Explorer has a workaround for this where if it enumerates the drives and sees one that didn’t send a notification about itself, then File Explorer will generate one which all other software then sees, so the drive appears everywhere once File Explorer sees it. But that’s still something that shouldn’t happen if the drive and drivers are working correctly and the notifications aren’t being blocked.

Antivirus could also get involved, but would probably block access to the whole drive from Opus, not just break the notifications, so that’s a less likely possibility.

You should not run Opus as admin. That's the opposite to what I said. :slight_smile:

If doing that made things work then something is wrong with your system as it's not sending drive change notifications properly or something is blocking them to non-admin processes (which is unusual; it's usually the other way around).

Well what I did was right click on directory opus shortcut from desktop and then from the right click menu pressed run as admin.. What this did was allow this pc to automatically update itself and display my external USB drive automatically.

Restarted computer checked to see if the drive came up automatically in This Pc and it did. Checked to see Directory Opus is elevated and it is not. Strange. Why would this happen must be something to do with the December windows update. Maybe you have to run it once in admin mode to get it to work after that it works without it.

Explore.exe should not be run as admin, but if it is running as admin on your machine then that explains all the problems you're seeing.

You should not run Opus or Explorer as admin. (Instead, use the Admin button within Opus to elevate individual windows, if you need to do lots of admin work and don't want a UAC prompt each time.)

Running Explorer as admin will break all sorts of things, unless you also run everything else as admin (in which case you may as well turn off UAC).

The strangest thing is that this has come back and does not refresh when usb drive connected to PC. Have to press F5 on the keyboard when i'm in directory opus, for each folder if i'm in this pc view. This suggests that directory opus beta latest is not picking up drive changes for some reason.

Not running elevated or in admin mode.

If it's affecting files/folders on the drive, not the drive itself in the This PC folder, please see here for how to diagnose what's going wrong:

Found out restarting directory opus solved the issue. So it looks like something to do with ditrectory opus and starting in windows

Was Opus running as Admin before or after the restart?

It wasn't running in admin at all.

I turned off directory opus, do it didn't start at startup and restarted and loaded up. Once loaded back up directory opus had not started up as expected. I then started up directory opus went yo this pc and then plugged USB drive in and it popped up as expected. I have a hunch that my problem could be that directory opus loads up before part of Windows and by it not starting on Windows loads solves this problrm

That's possible, but would be a bug in whatever is starting later on and not sending the notifications, since it should still send notifications to things that started before it.

Seeing what the diagnostics output when the problem is happening may shed some light on what's going on as well.

by taking off directory opus at start up I'm now not having any windows issue at all which indicates problems starting directory opus as windows starts. Tested with and without and i can say it definately is a directory opus problem.

My previous reply stands. If something else can't cope with being launched after Opus, it doesn't mean Opus is at fault. No other USB devices we've encountered work that way, so it points to an issue with the device rather than Opus.

At least from what we know so far.

The diagnostic information would be useful if you want us to examine it further. Please provide it if you want us to, as we have nothing to go on otherwise.

so taking it off starting when windows starts restating computer loading up no problems. Set directory opus to start at windows and problems reappear. tried it several times and from doing so the only conclusion I could make from my tests that starting directory opus at startup is causing the issues.

How do I get the info you want?

Details were in the link above: Changes to folders are not being detected

I've done a winaudt file for you if that helps but no way of uploading it. I have directory opus set to not start at windows

What's winaudt? That wasn't what I asked for.

cause I don't want to change settings now that its working ok. I thought you knew about this program. you can download it from the internet. I thought this file would help you.


WinAudit is an inventory utility for Windows computers. It creates a comprehensive report on a machine's configuration, hardware and software. WinAudit is free, open source and can be used or distributed by anyone. It is used by IT experts in academia, government, industry as well as security conscious professionals in the armed services, defence contractors, electricity generators and police forces.

If you want us to investigate, please provide the information we've requested.

starting windows without having directory opus start up at windows startup has solved the issue. Starting directory opus after windows has loaded up no problems, which indicates that directory opus startup at windows is the fault. I'm just reporting it as a fault. Me giving you debug info will show you nowt as it only happens when you set directory opus to run at windows startup, If I disable this feature and start computer without it starting up at windows startup then start it myself no issues.

I have produced a log file with Debug as requested though directory opus is set to not startup at windows which was causing the problem so it will show you nowt how do I send it to you