Dropbox virtual folder

After today's Win10 update, the DropBox folder now shows up in the Folder Tree pane with the title "dropbox-NamespaceExtensionRole.Personal" and can't be opened or expanded.

Uploading...

Coincidentally, this forum software shows a perpetual rotating icon with "Uploading 100%" and in the preview just the word "Uploading..." The file I tried to upload is a 58k screencap JPG. Sadly, it also won't let me click the "+ Create Topic" button.

...

I clicked "Cancel" by the "Uploading" status msg, and now the +Create Topic button is enabled, so I'll send it as is. Perhaps the screencap did upload and just isn't previewing.

Allen

The Dropbox virtual folder does appear to work correctly, but only when viewed or accessed through its official location as a folder under my Win10 username. The virtual folder displayed in the Folder Tree is still there, with the apparently unexpanded name, as described in my OP. And I'll try to upload a screencap:

Nope. Won't upload. But that's a separate issue, so I'll try to follow up later, on a separate thread.

Allen

What happens with the same folder in Explorer?

Have you tried reinstalling the dropbox software?

Same effect in Win10 Explorer. I'll try re-installing Dropbox.

Wish I could upload these screencaps. Each one is worth 1024 words. (!)

Allen

I killed Dropbox and associated services, preparatory to uninstalling it, and the weird folder name persists. Next, I'll reboot. Then uninstall Dropbox.

Stay tuned...

Allen

I rebooted (no change), uninstalled Dropbox (weird name disappeared), reinstalled latest Dropbox, and the weird name is back in DOpus and File Explorer.

Dropbox shows up correctly in FE as an entry in Quick Access, and as a folder under username. But it shows up as "dropbox.NamespaceExtensionRole.Personal" under Desktop.

In DOpus, it still shows up correctly under username, and still shows up incorrectly (as above) under Desktop.

So I'm guessing Dropbox is stuffing itself into the environment a little too enthusiastically.

Allen

If it's happening in Explorer as well then it's either a Dropbox or a Windows issue.

A quick search found someone else who had the same thing in Explorer back in January after an update: https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/something-strange-with-dropbox-namespace-extension/8d98fa5a-511c-4c48-ae6a-d367a1650e74

You can probably remove the unwanted folder by removing the file or registry setting that is adding it to the desktop, but I'm not familiar with exactly how Dropbox works.

Asking Dropbox for support is probably your best bet, since that's what's going wrong and they've probably had other people with the same question.

Yes, it's certainly not a DOpus problem!

In fact, I'm sorry to have wasted your time. Although perhaps this thread may clarify things for someone else who bumps into this.

Allen